With the help of a fellow builder i got a bit further.

I downgraded to version 2.0.9, but that gave me the dreaded "runtime error 5" problem as mentioned by others in this forum.

The solution for that was using an older version of phidgets.dll.

allthough the version number is is the same as the dll i was using before, the creation date of this one is older (18 nov 2004).
Using this dll solved my problems. both my 0/16/16 cards and my ledcards are recognized.

Unfortunately this dll made the 3.0.8 version crash, so its just a temp. solution and i still look forward to the new 3.0.9