Results 1 to 4 of 4
  1. #1
    10+ Posting Member
    Join Date
    Jul 2012
    Location
    Madison Al.
    Posts
    10
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Link2FS toggles lights instead of commanding on/off

    For example the serial data coming from the arduino Mega is C430 or C431. But P3Dv2 is behaving as if it is receiving a toggle command for the light when C430 is sent to Link2FS and does nothing when C431 is sent. The alternator, battery and gear switch are working correctly when sent their discrete codes. It seems as if the off/on 0/1 at the end of C43X is not being interpreted by Link2FS properly. All of the lights coded this way are acting the same. What can I do?

  2. #2
    500+ This must be a daytime job Jim NZ's Avatar
    Join Date
    Dec 2005
    Location
    New Zealand
    Posts
    764
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Link2FS toggles lights instead of commanding on/off

    Now that's interesting ,,, what plane are you using ?????
    I do all my testing using the default Baron and the default 737.

    Some add-on's don't talk all their stuff to simconnect so maybe it's that.

    But just the same ,,, in the extractions page ,, does the light indications work with your plane ??? ,,, just use the mouse and click on a light switch and see if any of the 10 indications change. (it's extractions(2) (lights on state)

    Is there key press codes that work from the keyboard ???
    Last edited by Jim NZ; 12-15-2013 at 10:39 PM.
    www.jimspage.co.nz/intro.htm
    All this and Liz still loves me ! !

  3. #3
    10+ Posting Member
    Join Date
    Jul 2012
    Location
    Madison Al.
    Posts
    10
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Link2FS toggles lights instead of commanding on/off

    My reply vanished!

    I was using LM's Carenado Bonanza so I tried the Baron 58 and got the same result. The light array was showing 0111111111 with no changes with either hard or soft switches. I keyed L and the array changed to all zeros and now everything works except for the taxi lights on both aircraft (soft and hard) switches. I must have something holding the taxi light off...

    Thanks for the reply and the awesome program. I am having a good time with it!
    Last edited by Nukem; 12-15-2013 at 11:47 PM. Reason: More info

  4. #4
    500+ This must be a daytime job Jim NZ's Avatar
    Join Date
    Dec 2005
    Location
    New Zealand
    Posts
    764
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Link2FS toggles lights instead of commanding on/off

    Glad you got it sorted Nukem ,,, thanks for helping out in that other thread too ,, different eyes looking at the same thing can sometimes see different things ,, it all helps in the end.

    Cheers ,,, Jim
    www.jimspage.co.nz/intro.htm
    All this and Liz still loves me ! !