Results 1 to 3 of 3
  1. #1
    10+ Posting Member
    Join Date
    Apr 2009
    Location
    UK - Cheltenham
    Posts
    15
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    ILS landing problems

    Hi,

    I am trying to perform an ILS landing using the Saitek Multifubction panel but keep running into problems.

    I am tuning NAV 1 to the correct freq for the runway
    Selecting the ILS runway heading
    Approaching the glideslope with autopilot on, 170Knts, flaps & gear up, ALT HDG & Speed hold on.
    Selecting Nav1 so as I can hear the morse code beep.

    As the green triangle passes just below centre I click APR on the panel.
    HDG (or NAV if I have been using that) turn off and the aircraft adjusts it's position, all the way to the runway, but the altitude remains fixed.
    I have tried it again and manually turned ALT hold off, but the aircraft still doesn't decsend under control.

    I then tried approaching as above, but this time clicking APP on the autopilot within FSX rather than on the panel. The HDG & ALT hold went off and the aircraft glided in beautifully.

    I then tried it again and it didn't work, I obviously did something correct that time and don't know what it is.

    Can anyone explain how I use the Saitek Multi panel to perform an ILS approach please? Before it drives me mad.

    I am flying the default MS Learjet by the way.

    Thanks
    Luke

  2. #2
    New Member
    Join Date
    Jun 2011
    Location
    Paris
    Posts
    1
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: ILS landing problems

    Hi Luke,

    I've got the same problem as yours with my Saitek MP in FS9. At first I thought maybe my FSUIPC was too old so I updated it to the last version 3.991 but the problem remains. So I thought perhaps because FS9 was old too and might have some compatibility problem with the new multi panel.
    But it seems that you were running in FSX? So should it be the problem of the multi panel itself?
    Have you got any resolution since then? Please kindly let me know.
    Thanks.

    André

  3. #3
    25+ Posting Member
    Join Date
    Dec 2009
    Location
    Trieste
    Posts
    38
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: ILS landing problems

    you need to go to the saitek forum, there is a little driver from an italian guy that it is fixing the problem since two years ago...
    with this new driver and tool you will operate the ILS without problems, for both fs9 and fsx.
    Try it, you need to search inside the forum the last version.

Similar Threads

  1. Old: Landing Gear
    By kiek in forum lekseecon Q&A and Discussions
    Replies: 8
    Last Post: 11-10-2015, 04:00 AM
  2. Landing without ILS
    By stepbk in forum General Builder Questions All Aircraft Types
    Replies: 2
    Last Post: 02-07-2010, 11:37 AM
  3. Potential buyer: VNAV problems, A/P problems?
    By 737aqua in forum PM General Q & A
    Replies: 13
    Last Post: 04-26-2008, 10:21 PM
  4. What a landing
    By Deesystems in forum MyCockpit Crew Rest (Off topic chat forum)
    Replies: 4
    Last Post: 12-26-2007, 11:17 PM
  5. New Landing
    By danieln62f in forum Welcome to MyCockpit New here? Introduce Yourself!
    Replies: 5
    Last Post: 12-03-2007, 10:29 PM