Results 1 to 3 of 3
  1. #1
    New Member
    Join Date
    Sep 2006
    Posts
    3
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Run-time error '401' when Setting Flap Gauge

    Hello,

    I installed fs2phidgets 4.2.9. I am using phidgets library 2.0. I have a phidgetservo controller which fs2phidgets recognizes. I select FLAPS_HANDLE from the FS Var Assignment pulldown list. I press Configure command button. I select Set Flap Gauge radio button. I get error:

    Run-time error '401'
    Can't show non-modal form when modal form is displayed.

    I'm trying to create a flap indicator. Can anyone help?

    Thanks,
    Mark

  2. #2
    builder
    Join Date
    Jan 2007
    Location
    Texas
    Posts
    587
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Mark,

    That is a bug. Thanks for pointing it out.
    I tried calibrating my flap gauge and had same error.
    Latest version fixes bug.
    Shoot me an email at alan@coconutair.com and I will send you a fixed version.

    Regards,
    Alan.

  3. #3
    25+ Posting Member stefanloss's Avatar
    Join Date
    Nov 2005
    Location
    Cologne, Germany
    Posts
    61
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Hi @ all,

    I´m still having the same problem with Version 2.3.1.

    When trying to set the flaps notches, I get this 401 runtime-error. Also, the throttle output seems to be somehow mixed up. Calibrating the throttle lever works fine here, but within FS I always have the throttle "jumping" back to idle. (With my other throttle hardware disabled, of course!)

    The strange thing is that, as long as I use ePhidgets, all this works perfectly, I only get these problems with real hardware Phidgets connected.


    Any Ideas?
    Last edited by stefanloss; 03-18-2008 at 12:51 PM. Reason: ...
    Stefan Loss
    Cologne, Germany

    737-NG
    Engravity, Project Magenta Full Boeing Software

Similar Threads

  1. Flap gauge won't work
    By leothevideo in forum OpenCockpits General Discussion
    Replies: 8
    Last Post: 11-01-2009, 03:54 AM
  2. Flaps '401' error
    By Melnato in forum Phidgets & Cockpit Simulator Builder
    Replies: 0
    Last Post: 02-28-2008, 05:16 AM
  3. Flap Notches setting inop
    By imported_737nut in forum FS2Phidget Users
    Replies: 4
    Last Post: 11-25-2006, 12:28 AM
  4. calibrating Flap gauge
    By Jan Pemöller in forum FS2Phidget Users
    Replies: 6
    Last Post: 10-06-2005, 10:00 AM
  5. Flap gauge adjustment
    By Skydvdan in forum Phidgets & Cockpit Simulator Builder
    Replies: 0
    Last Post: 12-09-2004, 10:51 PM