I have a GSA55 CIM and an IO Module which I cannot get working. I have been using it with no problems on Windows 7 64bit and FSX, until today. My connections are as follows:

CIM > IO Card > Attitude, Digital Analogue, Large Gauge Single Needle, and a series of LED's and switches.

The problem started when I had connected the power cable to the CIM and got an immediate spark. Thinking this was just a fuse blowing out, I replaced the fuse with the same ones that I have been using since I bought the unit. To verify, what are the proper fuses this should be running? I do not see the fuse settings anywhere on the card or the documentation.

Since then, I cannot get GSTEP to recognize any of the connected devices. The gauges all seem to power up, as I can see the backlights and numbers, but I cannot get the computer to connect with them. I have upgraded to GSTEP 7.0.8 from 7.0.5 and even updated the USB to Serial drivers from FTDI website. I did a new configuration in GSTEP, and when I click search connected units, it finds nothing. On the old configuration, they display a connection status of Unknown or Not Connected. I even tried disconnecting the IO Module card and connected the gauges directly into the CIM (in every available port), only with the same result.

The power connector I plugged in is the same one I always use, simply unplugged it to re-arrange wires and replugged it in. It comes direct from my computers power supply which is a 1200W PSU.

After visually inspecting both the CIM and the IO Module, there is nothing that can visably be seen as a problem.

Any ideas on what the problem may be? Any and all help is appreciated.

Thanks guys.