07-16-2016, 10:46 PM
Good night!, I am having a lot of trouble to set up my new Opencockpits MCDU V3. I have seen there is another Thread related with this topic but I have tried all the steps shown there to get the SIOC configuration working. However when I get to the step where you have to press the LSK1 nothing happens. I am using Prepar3d. I had never used SIOC before so I don't have a lot of knowledge about them. The scripts on the MCDU seem to be the ones for Project Magenta but I dont know if I need to replace them or something.

Thank you very much, hope someone knows how to solve this.

Andres :)

07-21-2016, 12:27 AM
Hi Andreas,

The Problem is that V3 uses a new Card. So first run SIOC the click MCDU and Start I guess. Thereafter the messages with sioc comes. After opening go there into edit script and double click on the only entry. Choose Keys from Master. (KeysCard is set and wrong!). Continu as normal.

07-25-2016, 08:01 AM
I'm trying to configure Opencockpits MCDU V3 with sioc_cretor and have the same issue as Andres above, When I start the keyboard configuration and press LSK1 key nothing happen, I need to kill sioc_creator. To me this is link to the fact the new MCDU V3 is not using USBKey card but USBFmc card (which is USBKey + few output). Can someone tell me if there is a possibility to configure it?
I tried to overwrite the card type changing
Var 0001, name keys, Link USB_KEYS, Device 13
Var 0001, name keys, Link IOCARD_KEYS, Device 13

In that case I get the key event in IOPConsel but A320FMGS CDU is still not working.

Can someone have the procedure?

Thanks Olivier

07-25-2016, 08:38 AM
As written above, you have to start Sioc_Creator. wait until LSK1 and so should be pushed then go to sioc and do the change as you have written. DO NOT CLOSE SIOC_CREATOR!!!

07-27-2016, 10:19 AM
Hello Niklas.

I changed the link type (with sioc EDIT) of the 'key' variable (generated by sioc_creator) so that key variable is linked to IOCARD_KEYS rather than USB_KEYS (while in CDU config state). From that step I was able to configure the CDU key mapping.

Once done, I did the same with JeeHellWare.ssi before launch A320FMGS suite. Result is good, my CDU is working perfectly :).

Thanks you very much Niklas for your advise, I was trying to make it work since several days.

Regards, Olivier

10-25-2016, 09:27 PM
Hello again guys, I have not been able to get it working yet =( , I have tried everything , I just think I dont get to understand how this works. If someone could help me via Teamviewer or something like that (probably some screen captures step by step) I would really appreciate it because I have no other idea of how to get it working.

Thank you very much!


10-26-2016, 02:01 AM
Hello Andres,

I try ro make screen shots next week. Unfortunatly JL will not change the sioc creator because he sees no reason in it. I suggest he can make a second page with V3, because its very easyer for us.

10-26-2016, 10:28 PM
Thank you very much Niklas, I would really appreciate it =D!! Will continue trying meanwhile but I dont know what have I done with this that it is not working haha.

11-06-2016, 07:08 AM
So soory for delay!

First Step, open SIOC and look for the device number of USBFMC V1.0.
Then click EditScript(make sure u load the jeeHell file) and look for Var001. if there is sth with Key-Card choose that one with double click. Then change the link to IOCARDS_Keys, name key(or fo_key) and set the device nr.(dispositivo).

Then open the A320FMGS folder _> hardware modules and open fmgs.iocp.
Look for MCDUkeys. copy and paste the following behind the "=": 56,64,72,80,88,87,86,85,84,83,74,82,79,78,77,76,75,75,67,66,67,68,69,70,71,65,63,62,54,55,32,31,30,24,23,22,16,15,14,8,7,6,61,60,59,58,57,53,52,51,50,49,29,28,27,26,25,21,20,19,18,17,13,12,11,10,9,5,4,3,2,1,

I have two MCDU V3 and I have done it like this way. Please check this and report ;)