View Full Version : FS2Phidgets 4.3.5 not recognizing hardware

05-04-2008, 04:54 PM

I just downloaded the newest FS2Phidgets release in combination with the latest phidgets.msi. I installed both after cleaning all older components from my PC (they never worked properly, anyway).

Now I have the problem that FS2Phidgets donīt recognize my I/O hardware (1 4Servo, 1 8/8/8, 1 4Relay). I can actually see 3 Phidgets with the according serial numbers in the "Phidgets" window, but 2 of them are labelled "0/0/0" and 1 is labeled "Servo". None of them can be activated or configured in any way.

The "Phidgets Library" shows

Phidget21 Version 2.1.4
Phidget COM Library 2.1.4
both from Apr 28 2008

Any ideas?

05-05-2008, 12:33 AM

Going back to Phidgets library 2.1.1 lets the program recognize the phidgets hardrware corrrectly, but brings back those annoying errors (error messages when closing the program, program not saving the configuration of the throttles and the flaps lever).

05-05-2008, 08:44 AM

Sorry to hear of your problem.

I am using the latest two Phidget downloads that Don recently put up here... and they seem to work fine for me. But I do not have the particular CARDS that you are running. I am running a couple of TextLCDs with their 8/8/8's and a stand alone encoder unit at the moment. All are recognized and their functions work fine.

Soon I will be adding a servo controller (wet compass) and another TextLCD-8/8/8. But that will not be VERY soon... so you shopuldn't wait for me to test that. Sorry.



05-26-2008, 01:52 PM
Hi to all,

installing FS2Phidgets 4.3.6 together with the phidgets.msi from the download section (build from 23-11-07) finally got it working...

..at least almost, as some values as the "latch" function or the inversion of axises are still not saved. But designating flaps settings, thrust levers etc. now works fine, which is quite a step ahead.:)