Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    DanFontan
    Guest

    Com2 TX Selection problems

    Am trying to select com2 TX but it will not work anyone else having trouble? Here is the ini code:

    [COM2_TX]
    Offset=3122
    Length=1
    FSType=Bitmap
    Bit=6

    Thanks for the help,

    Dan Fontan

  2. #2
    alandyer
    Guest
    Dan,

    You have the INI settings are correct.

    Did you remember to enable component ?
    (Have to ask )

    What version of FS are you using ?

    Create dummy tab within FS2Phidget and observe what values are being sent by FS when you change COM2 TX on FS screen.

    Alan.

  3. #3
    DanFontan
    Guest
    Enabled= checked
    FS version = 2004.1
    open dumy window = doesnt change FS settings, but com1 and both do change the settings.

    For some reason the 7th bit always has a one in it even though it is programmed for the 6th bit. I am seeing this on the input "fs value" of FS2phidget. Could this be causing it, and what is causing that bit to be a 1?

    Thanks for the help,

    Dan

  4. #4
    alandyer
    Guest
    Dan,

    The entire byte is displayed.
    FS and FSUIPC work with bytes.
    Some settings manipulate bits within a byte
    (This is the definition of bit mapping).
    I felt is was more helpful to display entire byte.

    That 7th bit is COM1 Transmit.


    Alan.

  5. #5
    DanFontan
    Guest
    Alan, Thanks for the quick responses and your dedication. Although I still can't get it to work and I noticed on the com1 byte its just all zeros, wouldn't it be the same as the com2 one since the same information is being passed through the same byte?

    Can someone please attempt the code in the first post to see if it works or if its just a problem with fsuipc of just fs itself?


    Thanks,

    Dan

  6. #6
    DanFontan
    Guest
    Alan I sent you a message if you would like to contact me directly to solve this issue my email is danfontan@cox.net or navalaircrewman@aol.com

  7. #7
    DanFontan
    Guest
    Ok, I was playing around with it and found out if I hold the button down to select com2 while i click on set FS to hardware, the 1 in the 7th bit dissapears, I let go of the button and com2 selects.

    Alan do you know what I'm doing wrong?

    Thanks for the help,

    Dan

  8. #8
    alandyer
    Guest
    Dan,

    Have you been using a toggle or momentary switch up until now for COM2 ?

    Alan.

  9. #9
    DanFontan
    Guest
    momentary. I even reassigned one of my on/off (basically a toggle) and to no joy.

  10. #10
    DanFontan
    Guest
    Alan, why would "com2 tx" read the 7th bit as a one and "com1 tx" doesn't read the 7th bit as a one or the 6th as a one when com2 is selected to tx?

Page 1 of 2 12 LastLast

Similar Threads

  1. GoFlight GF-166 COM1 COM2 and Ivap
    By KLM077 in forum MyCockpit Online Flying Discussion
    Replies: 0
    Last Post: 11-15-2010, 08:07 AM
  2. I/O Card Selection
    By Jetprovost in forum I/O Interfacing and Hardware
    Replies: 3
    Last Post: 03-06-2010, 07:17 AM
  3. Need Help with FSX Aircraft Selection
    By N242AM in forum General Builder Questions All Aircraft Types
    Replies: 4
    Last Post: 11-25-2009, 08:41 PM
  4. Help - Airspeed selection
    By Sheep in forum Computer Hardware Setup
    Replies: 0
    Last Post: 03-08-2007, 10:21 AM
  5. Phidget Selection
    By Larry Brown in forum Phidgets & Cockpit Simulator Builder
    Replies: 2
    Last Post: 03-09-2005, 06:23 AM