Results 1 to 8 of 8
  1. #1
    10+ Posting Member
    Join Date
    Nov 2004
    Posts
    13
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Question sound and servo question?

    I have a few questions. I have been playing around with the fs2phidgets program and one of my projects will be a vertical speed indicator using a servo. FS give a negative number when climbing and a positive number in a decent. But my servo will only react to the positive numbers. Is there anyway to place the servo in its center position when FS gives a 0, indicating level flight, and then increase the servo on negative numbers, indicating a climb, and decrease the servo on positive numbers, indicating a decent . I hope to use servos to build my gauges and this problem occurs in both VS gauge and turn indicator gauge. My second question is about the sound, I tried this out yesterday but nothing happened , I can hear the sounds in FS but not the added sounds from FS2Phidgets, the ini file show the path to the sound and I noticed a smin=0 and smax=0. Thinking these may be volume controls I tried changing the values with no success. I plan on building several gauges and instruments using fs2phidgets and servos, but I am just testing out the electronics to see if it will work before cutting the parts and putting in the time.

    Thanks for you help in advance
    Frank

  2. #2
    alandyer
    Guest
    Frank,

    What offset are you using or planning on using for V/S?

    There was a bug with negative numbers that I thought I had fixed.
    I am releasing 2.0.9 within next 24 hours that may fix this.

    Will also take care of your sound problem.
    What offset are you using to trigger sound?

    Regards,
    Alan.

  3. #3
    alandyer
    Guest
    Frank,

    2.0.9 is avaliable for download.

    Regards,
    Alan.

  4. #4
    10+ Posting Member
    Join Date
    Nov 2004
    Posts
    13
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Sound and servo question

    I was using the following offset for V/S

    [VERTICAL_SPEED]
    Offset=0842
    Length=2
    FSType=Proportional
    LoValue=-16834
    HiValue=16834

    And tried the sound with different offsets but interested in

    [ENGINE_1_START_SWITCH]
    Offset=0892
    Length=2

    to add a start and shutdown sound to a helicopter

  5. #5
    alandyer
    Guest
    Frank,

    Shouldn't matter what offset you assign.
    It's the state of digital input.
    When digital goes to true - "On" sound is triggered.
    When digital input goes to false - "Off" is triggered.
    Or vica versa if "invert" is set.

    Have you tried 2.0.9?

    Alan.

  6. #6
    10+ Posting Member
    Join Date
    Nov 2004
    Posts
    13
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Sound Question

    Downloaded and tried 2.0.9 sound now works when FS2Phidgets is the top program and flightsim is in the background. When I switch to flightsim I get a 9 to 14 second delay before the sound is played.

  7. #7
    alandyer
    Guest
    Frank,

    Are you running any Project Magenta software?

    Alan.

  8. #8
    10+ Posting Member
    Join Date
    Nov 2004
    Posts
    13
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Sound and Servo Question

    Yes I am running PM Reginal Jet on a independent client computer, FS2Phidgets is running on my FS computer along with goflight Equipment.

Similar Threads

  1. 180 degree servo acts as 90 degress servo
    By ke6jzs in forum FS2Phidget Users
    Replies: 2
    Last Post: 04-03-2011, 05:11 PM
  2. X-Plane Thunder Sound addon sound pack
    By Padraig in forum General X-Plane (Laminar Research)
    Replies: 4
    Last Post: 12-12-2009, 06:24 AM
  3. FS-BUS Servo Guage Question
    By Brian2sos in forum I/O Interfacing Hardware and Software
    Replies: 4
    Last Post: 04-06-2008, 10:48 PM
  4. Servo Question
    By rt72 in forum Cockpit Parts and Motion Platforms
    Replies: 1
    Last Post: 03-04-2008, 06:03 PM
  5. Question about servo activation
    By mauriceb in forum Phidgets & Cockpit Simulator Builder
    Replies: 2
    Last Post: 03-28-2006, 01:46 AM