Page 1 of 4 1234 LastLast
Results 1 to 10 of 31
  1. #1
    75+ Posting Member Tony's Avatar
    Join Date
    Dec 2006
    Location
    Strijen (NL)
    Posts
    99
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    pmSystems and PhidgetsLED64

    Hi,
    Can you help me with the setting of the LEDS pse,
    e.g. the "valve open" annunciator leds of the crossfeed valve:

    in software the annunciator is lit when the valve is travelling/moving and changes brightness when on;
    in hardware OVH the annunciator is only going on and of.

    how to set : led lit during "travelling"
    how to set : brightness

    The setting MAX2 does NOT work for me.
    (I have 2 LEDs in paralel per annunciator)

    Kind regards
    Tony

  2. #2
    75+ Posting Member Olympic260's Avatar
    Join Date
    Dec 2006
    Location
    Athens Greece
    Posts
    79
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Tony,

    What exactly mean 2 LED in parallel? At the phidget LED card you should connect in each output 2 LED for example LE00 ApuMain LE01 ApuMaint

    So the APU maint will have now two leds.

    On my setup using the max2 the led changes brigtness normaly. Have you checked that the MAX4 option is not checked at the PM menu?
    Chris

  3. #3
    75+ Posting Member Tony's Avatar
    Join Date
    Dec 2006
    Location
    Strijen (NL)
    Posts
    99
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Hi Christos,

    I have 2 leds per annunciator, so to every PhidgetLED64 position there are 2 LEDs.

    I have no MAX4 in PM menu.
    You must be using an old version I think.

    Tony

  4. #4
    1000+ Poster - Fantastic Contributor Bob Reed's Avatar
    Join Date
    Oct 2005
    Location
    Holley, New York U.S.A.
    Posts
    1,880
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Hold on a couple minutes I am not at that computer right now but I will be in a short. This is easy and it does work. I hooked them in parallel too. As soon as I get the other computer up I will post it here.
    Bob Reed

  5. #5
    75+ Posting Member Tony's Avatar
    Join Date
    Dec 2006
    Location
    Strijen (NL)
    Posts
    99
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Standby with all computers running

  6. #6
    builder
    Join Date
    Jan 2007
    Location
    Texas
    Posts
    587
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Here is what Tony wants to do:
    The Fuel valve annunciators on the Boeing 737 overhead have 3 states:
    Off, Dim and Bright
    Depending on whether valve is open, in transit and closed.
    pmSystems' on-screen representation for valve displays 3 states accurately.

    The LED-64 entries in the phidgets.txt file have a MAX2 and MAX4 parameter, in the provided examples, to facilitate above scenario.

    Appears to not be working:
    Only sets LED On and Off without the intervening brightness settings.

    Hope this helps.

  7. #7
    builder
    Join Date
    Jan 2007
    Location
    Texas
    Posts
    587
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Tried on my set-up with latest pmSystems build 98.
    Tried SparValve1 and 2 EngValve1 and 2 with both MAX2 and MAX4 parameters. Only get an On and Off brightness output.

  8. #8
    75+ Posting Member Tony's Avatar
    Join Date
    Dec 2006
    Location
    Strijen (NL)
    Posts
    99
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    What happened Bob.....

  9. #9
    Executive Vice President, MyCockpit


    Matt Olieman's Avatar
    Join Date
    Oct 2005
    Location
    Ocala, FL USA
    Posts
    3,163
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    I think Bob got lost into his computer

  10. #10
    1000+ Poster - Fantastic Contributor Bob Reed's Avatar
    Join Date
    Oct 2005
    Location
    Holley, New York U.S.A.
    Posts
    1,880
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    No, sorry about that guys... I realized after I posted you are using FSPhidgets. My overhead does not. So my code would be no good to you. You will have to wait to see what Alan comes up with! Looks like something is broke between FSPhidgets and PMSystems. They will get it sorted out!
    Bob Reed

Page 1 of 4 1234 LastLast

Similar Threads

  1. MIP in PMSystems??
    By Fuglsang in forum PMSystems
    Replies: 4
    Last Post: 02-11-2009, 02:31 PM
  2. Pmsystems
    By kenlie_no in forum PMSystems
    Replies: 3
    Last Post: 12-31-2008, 07:06 PM
  3. pmSystems and PhidgetsLED64
    By avan1001 in forum Phidgets & Cockpit Simulator Builder
    Replies: 1
    Last Post: 01-23-2007, 11:32 AM
  4. PMSystems
    By Andras in forum FS2Phidget Users
    Replies: 7
    Last Post: 10-22-2004, 04:42 PM