Results 1 to 6 of 6

Thread: Arduino Library problem

  1. #1
    75+ Posting Member
    Join Date
    Nov 2011
    Location
    UK
    Posts
    83

    Arduino Library problem

    After taking some time out due to a bust computer I am now back relearning the art of arduino and installing all of the necessary bits back onto the PC. What is weird is that I have installed the quadrature.h library which is linked from Jim's link2fs page. When I try and compile I get this:-

    C:\Users\FS\Documents\Arduino\libraries\Quadrature/Quadrature.h:19:24: fatal error: WConstants.h: No such file or directory


    compilation terminated

    Any ideas?
    Many thanks
    Marc

  2. #2
    150+ Forum Groupie BuzziBi's Avatar
    Join Date
    Mar 2013
    Location
    Norway
    Posts
    276

    Re: Arduino Library problem

    Google the "WConstants.h"
    Life was hard, but then came Windows 7.
    Now we can fly! --------
    --------

  3. #3
    75+ Posting Member
    Join Date
    Nov 2011
    Location
    UK
    Posts
    83

    Re: Arduino Library problem

    Thankyou, I had a looked through the link2fs site again and realised that I had downloaded the quadrature file for the old ide.
    All working now
    Regards
    Marc

  4. #4
    75+ Posting Member
    Join Date
    Nov 2011
    Location
    UK
    Posts
    83

    Re: Arduino Library problem

    Thought I had this one sorted. None of my encoders are working and I know it is not the code. I checked that I had the right quadrature 2 library off the link2fs site. But when I add zip file from the IDE it says specified folder/zip file does not contain a valid library.
    Any ideas?
    Many thanks
    Marc

  5. #5
    75+ Posting Member
    Join Date
    Nov 2011
    Location
    UK
    Posts
    83

    Re: Arduino Library problem

    Don't worry, all sorted now, not sure what I did but it is all working.
    Thanks

  6. #6
    150+ Forum Groupie BushPilotWannabe's Avatar
    Join Date
    Jan 2014
    Location
    Alberta, Canada
    Posts
    203

    Re: Arduino Library problem

    Been There
    ---CYXD ----- TWR --- GND ------ Closed
    ILS-- NDB -- 119.1 -- 121.9 ---- 11/2013