Results 1 to 5 of 5

Thread: SIOC Locking up

  1. #1
    150+ Forum Groupie
    Join Date
    Aug 2008
    Location
    Dallas, Texas
    Posts
    188
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    SIOC Locking up

    A few days ago I started up my cockpit computers, started Prosim737 and SIOC but none of my switches etc were working. I tried reloading my script and SIOC locked up. All my Devices are listed in the Device window. SIOC Monitor and IOCPConsole both will open but nothing works. I tried reloading my script and SIOC locked up. The log window said "RELOADING SIOC". Exit would not work so I had to use the Task Manager to close it. Restarting my computer didn't help. I finally uninstalled and reinstalled SIOC but that didn't work. I uninstalled my AVAST Antivirus thinging maybe it was the culprit. I finally contacted Open Cockpits Support and they said there could be an IP Address conflict with another program. All the information I googled dealt with other computers on the network, not with programs. Other than a complete Windows, etc. reinstall (nightmare) I don't know what to try next. Has anyone else had this happen before?

    Jerry

  2. #2
    500+ This must be a daytime job



    Join Date
    Jan 2007
    Location
    NEW ZEALAND
    Posts
    839
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: SIOC Locking up

    Jerry,
    In sioc you can change the port number used, maybe you could try another number.
    Les

  3. #3
    10+ Posting Member
    Join Date
    Dec 2010
    Location
    Netherlands
    Posts
    20
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: SIOC Locking up

    Have you tried to restore your system to an earlier reset point? Because something must have changed since the last time all worked well. Windows update perhaps?

    Jan

  4. #4
    150+ Forum Groupie
    Join Date
    Aug 2008
    Location
    Dallas, Texas
    Posts
    188
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: SIOC Locking up

    Quote Originally Posted by anijan View Post
    Have you tried to restore your system to an earlier reset point?
    Jan
    Yes, I restored it to a reset point on 8/27/16 but it didn't help. I tried some random port numbers, didn't work, but how do you find out what ports are actually available. I've googled information on that but found nothing.

    Jerry

  5. #5
    150+ Forum Groupie
    Join Date
    Aug 2008
    Location
    Dallas, Texas
    Posts
    188
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: SIOC Locking up

    It appears that I fixed my SIOC not working problem. I think it was a hardware issue. The USB connector on one of my Expansion Cards was loose. I wiggled it a little and SIOC started working. Guess I need to replace it. If that wasn't the problem then it was a coincidence and something fixed itself.

    I think I may have had a misconception about Prosim. Do I just need to use the definition file for Prosim, change the inputs/outputs and Prosim handles all the calculations? Maybe that's why I'm having some issues. I thought I needed to tell the switches, etc. what to do in my script.

    Jerry