Results 1 to 3 of 3
  1. #1
    New Member
    Join Date
    Nov 2011
    Location
    Kent, UK
    Posts
    2
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Struggling with 7-seg displays

    Hi,

    I have a homebuilt MCP which worked fine with Lexseecon, but I am trying to connect it to PSXseecon. Presently, 7-segs are only producing 0's. I've added 1.digit.txt to the compile, but still no luck.

    Below is my code:...........

    Var 2034 Static name WdoVs
    {
    CALL &DecBCD3 &WdoVs
    &D_Vs0 = &Digit0
    &D_Vs1 = &Digit1
    &D_Vs2 = &Digit2
    }

    Var 9200 name D_Vs0 Link IOCARD_DISPLAY Device 0 Digit 0 Numbers 1
    Var 9201 name D_Vs1 Link IOCARD_DISPLAY Device 0 Digit 1 Numbers 1
    Var 9202 name D_Vs2 Link IOCARD_DISPLAY Device 0 Digit 2 Numbers 1

    Digits are linked to my display card numbers. Everything checks out with controlador, SIOC monitor software etc. All LEDs, push buttons and rotaries work perfectly and are reflected by their counterparts in PSX. Only the 7-segs are giving me a headache.

    I realise that I am probably making a really silly mistake, but help from any compassionate simmers would be very welcomed.

    I'm also confused by the fact that there are working LED variables in the 9000's, but they are not to be found in any listings?

    Cheers,
    Richard Goldstein

  2. #2
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,202
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Struggling with 7-seg displays

    Hello Richard,

    Could it be that you have not checked Situation->Equipment>MCP and displays LCD version?


    Quote Originally Posted by Vulpecula View Post
    I'm also confused by the fact that there are working LED variables in the 9000's, but they are not to be found in any listings?
    I'm sorry, but I don't know what you mean. The "9000 variables" in your listing are not PSXseecon variables (they do not have the keyword Static attached...and are not in the right range).

    Cheers,
    Nico
    Last edited by kiek; 11-30-2014 at 05:36 AM.

  3. #3
    New Member
    Join Date
    Nov 2011
    Location
    Kent, UK
    Posts
    2
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Struggling with 7-seg displays

    Thanks Nico.

    You are, of course, correct. Thanks for this great piece of software. Everything works perfectly now.

    Forget the variables comment. I hadn't programmed SIOC for a few years and had forgotten some of the basics.

    Regards,
    Richard Goldstein