Results 1 to 4 of 4
  1. #1
    75+ Posting Member
    Join Date
    Jun 2011
    Location
    FRANCE
    Posts
    121
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Start valve handles

    Today I made my first flight with a PW model. I always flew RR models with the same hardware and code, and never had the following problem.

    I have hardware push switches on my overhead for engine start handles. Today, during engine start procedure, the virtual start handle didn't come back to initial position after N1 reached 20%, giving me an EICAS caution message for each engine. I had to push one more time my hardware push switch to see the virtual handle come back into release position. As I told you before, I never had any problem on RR model, and never tested GE model at this time. Here is my piece of code relative to the start handle 1 (all the handles are coded the same way) :

    Code:
    Var 1267, name EngStartSw1, static     // ENGINE START 1 HANDLE (PSX)
    
    Var 7011, name EngStartSw1S, static, Link IOCARD_SW, Device 11, Input 184, Type P     // ENGINE START 1 HANDLE (SIOC)
    {
      &EngStartSw1 = CHANGEBITN 0 ,&EngStartSw1
    }
    
    
    Var 4702, name EngSw1Position, static, Link SUBRUTINE     // ENGINE START 1 HANDLE POSITION (PSX)
    {
      C0 = &EngStartSw1 = 1
      L0 = MOD &EngSw1Position ,2
      C1 = L0 = 0
      IF C0 AND C1
      {
        &EngStartSw1 = 0    
      }
    }
    Could you make the test with your hardware and PW model and report if you have the same problem ?

  2. #2
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,198
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Start valve handles

    Hello JP,

    I have the same problem now. It looks 1.0.13 introduced this problem. I made a few changes in the provisioning of the virtual switch variables.

    Will have a look, and fix it.

    Regards,
    Nico
    Last edited by kiek; 09-30-2014 at 03:35 PM.

  3. #3
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,198
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Start valve handles

    Fixed in version 1.0.15 (available for download).
    Cheers,
    Nico

  4. #4
    75+ Posting Member
    Join Date
    Jun 2011
    Location
    FRANCE
    Posts
    121
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Start valve handles

    Thank you !