Results 1 to 3 of 3
  1. #1
    75+ Posting Member
    Join Date
    Feb 2010
    Location
    London
    Posts
    87
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Starting wih arduino and Link2FS problems all ready):)

    Hi there
    I bumped in to Link2S some time ago,and it seems great stuff especially for LCD and 7 segment displays.

    BIG BIG THANK YOU JIM

    Anyway i got the Arduino mega an started to play with it.
    Basically in my first sketch I want to light up LED when I press 'L' for lights on my keyboard.

    So this is what I come up with so far

    Arduino connected to Link2FS

    Untitled.png

    I tikes the lights on the list
    So in of state it is 0000000000 and in on state it is 1111111111
    In the monitor Link2FS ends the f000000 and f111111

    And the script that I wrote is

    int inbyte;
    void setup()
    {

    Serial.begin(9600);
    pinMode(13,OUTPUT);
    digitalWrite(13,LOW);
    }
    void loop()
    {
    if(Serial.available()>0)
    {
    inbyte=Serial.read();
    }
    if(inbyte=='L')
    {
    digitalWrite(13,HIGH);
    }
    else
    {
    digitalWrite(13,LOW);
    }
    }

    and it's not working

    The data are reaching the card becouse see the tansfer LED flashes when ever press L

    but it is LED on arduino connected to pin 13 that wont light up.
    I ha to something with the code.
    Please help

  2. #2
    500+ This must be a daytime job Jim NZ's Avatar
    Join Date
    Dec 2005
    Location
    New Zealand
    Posts
    764
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Starting wih arduino and Link2FS problems all ready):)

    Bart ,,, there are so many fundamental things wrong with that code for the Multi ,, I'm not even going to start.

    The best thing to do is to read the documentation that is supplied with my Multi and study the sample INO's ,,, there is even one there for the lights. (all individual tho) but you should quickly get the idea.

    Good luck ,,, Jim
    www.jimspage.co.nz/intro.htm
    All this and Liz still loves me ! !

  3. #3
    75+ Posting Member
    Join Date
    Feb 2010
    Location
    London
    Posts
    87
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Starting wih arduino and Link2FS problems all ready):)

    Hi again
    Today I got my LCD 20x4
    bit of up hill at the beginning but it works at the end with you code of course,I even manage to change thing or to.
    Anyway fro tomorrow I am on the row to adapt the code.

    And another thing Update of liquidcrystal from https://bitbucket.org/fmalpartida/ne...stal/downloads help me to solve the problem with LCD
    as at the begrudging I was getting ??????/ee_ on my display

  4. Thanks Jim NZ thanked for this post