Results 1 to 4 of 4
  1. #1
    10+ Posting Member
    Join Date
    Aug 2012
    Location
    SA
    Posts
    18
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    two or more stepper I/0 boards sioc problem

    Halo

    Does anyone know what can be the problem when conecting two or more OC stepper boards, only one board works why ?
    here is my .INI file


    USBStepper=0,53
    USBStepper=0,55
    USBStepper=0,56
    USBStepper=0,57

    Only USBStepper=0,53 is working, using the same instument

  2. #2
    500+ This must be a daytime job
    Join Date
    Jul 2013
    Posts
    948
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: two or more stepper I/0 boards sioc problem

    It is explained in the sioc.ini file!
    You should amend your .ini file to

    USBStepper=0,53
    USBStepper=1,55
    USBStepper=2,56
    USBStepper=3,57

    Your script should then reference the correct card by using the appropriate device attribute eg device 0, device 1 device 2 etc

    David

  3. #3
    150+ Forum Groupie


    Perik's Avatar
    Join Date
    Aug 2007
    Location
    NORWAY
    Posts
    229
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: two or more stepper I/0 boards sioc problem

    Hello Marnus

    Here is a link to a document written by Morten Haughom.

    It's a well written tutorial about combining sioc script and with
    an initial part explaining the basics about device numbering and configuration setup.

    It's a must read when dealing with SIOC and OC hardware.

    http://www.opencockpits.com/images/d...20tutorial.pdf
    Regards,
    Per-Erik
    www.hoddo.net

  4. #4
    10+ Posting Member
    Join Date
    Aug 2012
    Location
    SA
    Posts
    18
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: two or more stepper I/0 boards sioc problem

    Thanks alot

    I will check it out this morning, see if i get something right for this RMI