Results 1 to 4 of 4
  1. #1
    75+ Posting Member BuildABoeing's Avatar
    Join Date
    Sep 2012
    Location
    Denmark
    Posts
    80
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Question Noob question about rotary encoders

    Okay this might be a totally novice question about rotary encoders.
    I guess I just need to understand the basics on these things.

    I have hooked a CTS 288 encoder on to my OC master card. But when looking at the SIOC monitor it does not act as supposed to.
    It is hooked up with the GND in center and the two sides as inputs.

    When I turn the encoder the red LED on the USB expansion card flashes. I interpret this as an input is being registered by the card.

    But when looking at "SIOC monitor" not all movements are registered.
    There is no direct pattern but only like every 3-4 clicks. And in the 00-10-11-01 sequence I only get 00s 10s and 11s.

    Is there some sort of basic setting that most be enabled for rotary encoders to work directly on master cards?

    I remember a few years ago I had a BU0836X card and you had to run a program to make the encoders work. I am wondering if I am overlooking something as basic

    I am sorry if this a an embarrassing newbie question.

    Cheers

    Peter
    Best wishes, Peter
    Building a B737NG - Blog: BuildABoing

  2. #2
    150+ Forum Groupie


    jonesthesoftware's Avatar
    Join Date
    Jul 2009
    Location
    aberdare, south wales UK
    Posts
    276
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Noob question about rotary encoders

    Hi Peter
    do you have a 5V supply to the master card? No software setup required for OC cards. Just run "controllador.exe" to check your encoder. You can get this from OC website.
    regards
    geoff

  3. #3
    150+ Forum Groupie


    Perik's Avatar
    Join Date
    Aug 2007
    Location
    NORWAY
    Posts
    229
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Noob question about rotary encoders

    Regards,
    Per-Erik
    www.hoddo.net

  4. #4
    75+ Posting Member BuildABoeing's Avatar
    Join Date
    Sep 2012
    Location
    Denmark
    Posts
    80
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Noob question about rotary encoders

    Hi guys.
    Apparently it had to do with the full moon... Or something as random.
    Because when I tried again to day it all worked flawless. Plug and Play.
    But thanks for the help!

    Cheers

    Peter
    Best wishes, Peter
    Building a B737NG - Blog: BuildABoing