Results 1 to 9 of 9

Thread: yaw damper

  1. #1
    Our new friend needs to reach 10 posts to get to the next flight level
    Join Date
    Mar 2012
    Location
    rome
    Posts
    9
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    yaw damper

    hello nikko
    I thank you for the help you have given me so far.
    I have a problem with the lights of the yaw damper inop, the ON light up properly ... but not those INOP.
    I used this script:
    / / ************************************************ **************
    / / Yaw Damper 2.2

    Var 701 STATIC
    {
    O_LftYawD = 0 & TESTBIT v701
    O_LftYawDInop = 1 & TESTBIT v701
    O_RgtYawD = 2 & TESTBIT v701
    O_RgtYawDInop = 3 & TESTBIT v701
    }

    Var 2202 name O_LftYawD Link IOCARD_OUT Output 11
    Var 2203 name O_LftYawDInop Link IOCARD_OUT Output 12
    Var 2204 name O_RgtYawD Link IOCARD_OUT Output 14
    Var 2205 name O_RgtYawDInop Link IOCARD_OUT Output 13

    Var 39 STATIC Link IOCARD_SW Input 1 Type P / / L Yaw Damper
    Var 40 STATIC Link IOCARD_SW Input 0 Type P / / R Yaw Damper

    / / ************************************************ ************

    everything works except the lights of yaw damper INOP.

    ps: the setup of the cards is ok .. I tried them with other script is working well.

    tks and regards

  2. #2
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,202
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: yaw damper

    You should write &O_LftYawD = TESTBIT v701 0 and so on ...
    Last edited by kiek; 09-19-2012 at 03:54 AM.

  3. #3
    Our new friend needs to reach 10 posts to get to the next flight level
    Join Date
    Mar 2012
    Location
    rome
    Posts
    9
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: yaw damper

    sorry Nikko, but i think that i have explained wrong the problem..

    i have compiled only one script in file called yawdamper and i have writed this text:

    //**************************************************************
    // Yaw Damper 2.2
    Var 701 STATIC
    {
    &O_LftYawD = TESTBIT v701 0
    &O_LftYawDInop = TESTBIT v701 1
    &O_RgtYawD = TESTBIT v701 2
    &O_RgtYawDInop = TESTBIT v701 3
    }
    Var 2202 name O_LftYawD Link IOCARD_OUT Output 86
    Var 2203 name O_LftYawDInop Link IOCARD_OUT Output 82
    Var 2204 name O_RgtYawD Link IOCARD_OUT Output 88
    Var 2205 name O_RgtYawDInop Link IOCARD_OUT Output 84
    Var 39 STATIC Link IOCARD_SW Input 72 Type P // L Yaw Damper
    Var 40 STATIC Link IOCARD_SW Input 77 Type P // R Yaw Damper
    //************************************************************

    next i have start fsx whit a level 767 and i have opened the OVH window.
    I have started the sioc and i have compiled the file yawdamper.txt in output file sioc.ssi.Next i have reloaded and i have started lekseecon..all green, and i have checked whit sioc monitor all the inputs and outputs...all ok!
    In fsx the yaw damper is on and same in my yaw damper ..when i push the L and R yaw dumper's button the light switch off, but the INOP light don't switch on (in fsx's OVH it is on and INOP in amber). why?

    P.s sorry for a lot a questions but i have started now whit your beautiful program, but my technical skill and my english aren't good .

    best regards

    kriss

  4. #4
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,202
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: yaw damper

    Hi,

    Please post your lekseecon.log and sioc.ini files.

    Nico

  5. #5
    Our new friend needs to reach 10 posts to get to the next flight level
    Join Date
    Mar 2012
    Location
    rome
    Posts
    9
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: yaw damper

    my oc configuration is:
    1usbexp
    1master
    1output card
    1input card
    1displayII card

    my lekseecon.log is:

    lekseecon version 9.1
    Searching for sioc.ini at drives C: D:
    C:\Program Files (x86)\IOCards\SIOC\sioc.ini found
    PORT=8092
    CONFIG_FILE=C:\Program Files (x86)\IOCards\SIOC\sioc.ssi
    Parameters from sioc.ini were taken
    Number of lekseecon variable(-s) detected: 3
    39 40 701
    SDK connected
    SDK responds to commands
    SIOC connected
    2 variables registered at SIOC server
    Initial values received from SIOC Server
    Running...


    my sioc.ini is:

    [SIOC]
    IOCP_port=8092
    IOCP_timeout=4000
    Minimized=No
    toggle_delay=20
    CONFIG_FILE=.\sioc.ssi
    [IOCARDS MODULE]
    IOCard_disable=No
    IOCard_LPT=No
    [MASTERS]
    MASTER=0,4,1,38
    [USBKEYS]
    USBKeys=4,37
    [FSUIPC MODULE]
    FSUipcdisable=Yes
    FSUipcRefresh=200
    [IOCP CLIENTS MODULES]
    IOCPini_delay=3000
    IOCPclient0_disable=Yes
    IOCPclient0_host=localhost
    IOCPclient0_port=8091
    IOCPclient1_disable=Yes
    IOCPclient1_host=localhost
    IOCPclient1_port=8092
    [SOUND MODULE]
    Sound_disable=No
    Volume=100
    [ #1 ]
    Sound=*lks\Terrain.wav,-1,-1,-1
    [ #2 ]
    Sound=*lks\TooLowTerr.wav,-1,-1,-1
    [ #3 ]
    Sound=*lks\TooLowGear.wav,-1,-1,-1
    [ #4 ]
    Sound=*lks\TerrTerrPullUp.wav,-1,-1,-1
    [ #5 ]
    Sound=*lks\TooLowFlap.wav,-1,-1,-1
    [ #6 ]
    Sound=*lks\Glideslope.wav,-1,50,-1
    [ #7 ]
    Sound=*lks\Glideslope.wav,-1,100,-1
    [ #8 ]
    Sound=*lks\SinkRate.wav,-1,-1,-1
    [ #9 ]
    Sound=*lks\DontSink.wav,-1,-1,-1
    [ #10 ]
    Sound=*lks\PullUp.wav,-1,-1,-1
    [ #11 ]
    Sound=*lks\Windshear.wav,-1,-1,-1
    [ #12 ]
    Sound=lks\APDisc.wav,-1,-1,-1
    [ #13 ]
    Sound=lks\BankAngle.wav,-1,-1,-1
    [ #14 ]
    Sound=*lks\BankAngle.wav,-1,-1,-1
    [ #15 ]
    Sound=lks\2500.wav,-1,-1,-1
    [ #16 ]
    Sound=lks\1000.wav,-1,-1,-1
    [ #17 ]
    Sound=lks\500.wav,-1,-1,-1
    [ #18 ]
    Sound=lks\400.wav,-1,-1,-1
    [ #19 ]
    Sound=lks\300.wav,-1,-1,-1
    [ #20 ]
    Sound=lks\200.wav,-1,-1,-1
    [ #21 ]
    Sound=lks\100.wav,-1,-1,-1
    [ #22 ]
    Sound=lks\50.wav,-1,-1,-1
    [ #23 ]
    Sound=lks\40.wav,-1,-1,-1
    [ #24 ]
    Sound=lks\30.wav,-1,-1,-1
    [ #25 ]
    Sound=lks\20.wav,-1,-1,-1
    [ #26 ]
    Sound=lks\10.wav,-1,-1,-1
    [ #27 ]
    Sound=lks\ApproachingMinimums.wav,-1,-1,-1
    [ #28 ]
    Sound=lks\Minimums.wav,-1,-1,-1
    [ #29 ]
    Sound=lks\AltHorn.wav,-1,-1,-1
    [ #30 ]
    Sound=lks\MasterWarn.wav,-1,-1,-1
    [ #31 ]
    Sound=lks\MasterCaut.wav,-1,-1,-1

  6. #6
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,202
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: yaw damper

    Hi Kriss,
    Strange...
    I do not see any real problems in your files... lekseecon is ok, I have tried your file here in my sim, without any problems and also none of the other users have reported this. So there must be something else that is causing it, but what?

    I can only give you some checks/advise:

    - check in your SIOC window that 38 is indeed the IDX of the USB expansion card.
    - check if you see any strange things in the SIOC window
    - remove the USBKeys entry from your sioc.ini (You do not need it)
    - run alls programs 'as Administrator'
    - check what happens if you push the yaw damper buttons with the mouse in the OVH panel
    - last resort: install SIOC and lekseecon at drive D:

    regards,
    Nico
    Last edited by kiek; 09-24-2012 at 12:34 PM.

  7. #7
    Our new friend needs to reach 10 posts to get to the next flight level
    Join Date
    Mar 2012
    Location
    rome
    Posts
    9
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: yaw damper

    Hi Nico

    I have tried all your check and advise but the inop don't light...other all switch,light,rotary,display...etc they go perfectly .. Patience ...

    Tks for all and for your fantastic work..

    Regards

    Kriss

  8. #8
    150+ Forum Groupie


    Perik's Avatar
    Join Date
    Aug 2007
    Location
    NORWAY
    Posts
    229
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: yaw damper

    Kriss,

    Did you get the Yaw INOP to work?
    At my end all works great.
    Do you use a toggle, latching or a momentary switch?
    Could you send your IOCPconsole output and what do SIOCMonitor show?
    Regards,
    Per-Erik
    www.hoddo.net

  9. #9
    Our new friend needs to reach 10 posts to get to the next flight level
    Join Date
    Mar 2012
    Location
    rome
    Posts
    9
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: yaw damper

    Hi perik

    I have resolved the problem, i dont know the solution but i have resolved

    Thank for your interest

    Regards