Header Fly Engravity
Results 1 to 7 of 7
  1. #1
    25+ Posting Member
    Join Date
    Apr 2007
    Location
    Australia
    Posts
    39
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Assigned Sound continuously plays

    Hi all,

    I am using fs2phidgets to assign a ding sound when an FMC message appears on my CDU. I had originally assigned the sound using fs2phidgets ver. 4.2.9. I have recently upgraded to version 4.3.66 on a new PC and have re-assigned all my functions including the sound when the message appears. However 4.3.66 version of fs2phidgets causes the sound to play continuously instead of hearing the "ding" sound once.

    I can appreciate that the sound is activated when the output is "On" and while the message remains the state of the output is "On" so the sound should play BUT I did not observe this behaviour with the older version of fs2phidgets.

    Is there a way to tell fs2phidgets to only play the sound once when the output is On? I am using an 8/8/8 boar on Win7 32bit flying FSX with the default b737 and connected to pmSystems.

    Cheers
    luke

  2. #2
    builder
    Join Date
    Jan 2007
    Location
    Texas
    Posts
    577
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Assigned Sound continuously plays

    Luke,

    Digital FSVariables should only play sound when state changes. That should be true for both digital input and output.
    Behaviour you have decribed is incorrect. I will try and replicate what you are observing and fix.

    Regards,
    Alan

  3. #3
    builder
    Join Date
    Jan 2007
    Location
    Texas
    Posts
    577
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Assigned Sound continuously plays

    What type of hardware did you assign sound to?

  4. #4
    builder
    Join Date
    Jan 2007
    Location
    Texas
    Posts
    577
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Assigned Sound continuously plays

    Luke,

    I was able to replicate problem and fixed code. Send me an email to alan@coconutair.com. I will then email you the updated version to try out. If it works ok for you, I will upload to this web site.

    Regards,
    Alan

  5. #5
    25+ Posting Member
    Join Date
    Apr 2007
    Location
    Australia
    Posts
    39
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Assigned Sound continuously plays

    Quote Originally Posted by CocnutAir View Post
    Luke,

    I was able to replicate problem and fixed code. Send me an email to alan@coconutair.com. I will then email you the updated version to try out. If it works ok for you, I will upload to this web site.

    Regards,
    Alan
    Alan,

    I am assigning a LED (annunciator) to the output of my 8/8/8 phidgets card.

    Thank you for looking into this issue so promptly. I'll send you an email from my hotmail account later today.



    Many thanks
    Luke

  6. #6
    builder
    Join Date
    Jan 2007
    Location
    Texas
    Posts
    577
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Assigned Sound continuously plays

    Luke,

    Latest version I sent you requires a newer Phidget driver.
    The April version is little buggy.
    The new version of Fs2Phidgets (that I sent you) has two panels at the top left of the Fs2Phidget window.
    One panel displays Required Phidget driver version, the other the Installed Phidget driver version.
    If these match the Installed Version panel is annunciated green, otherwise panel annunciates yellow.
    I sent you email and posted here.
    Regards,
    Alan
    Last edited by CocnutAir; 05-10-2012 at 12:48 AM.

  7. #7
    builder
    Join Date
    Jan 2007
    Location
    Texas
    Posts
    577
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Assigned Sound continuously plays

    There is distinction between version and build.
    Phidget driver version: 2.1.8.
    Build for version 2.1.8: May 3 2012