Results 1 to 6 of 6
  1. #1
    25+ Posting Member
    Join Date
    Apr 2007
    Location
    Australia
    Posts
    38
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Landing Gear Handle - Offset 0BE8 Problem - Not recognised

    Hi All,

    I've recently completed installing fs2phidgets after upgrading to FSX from FS2004.

    I am having a problem operating my landing gear using FSX connected to an 8/8/8 phidgets board using fs2phidgets version 4.3.65 on Win 7 (32 Bit). The phidgets board is directly attached to the FSX computer and fs2phidgets is running on the FSX computer as well.

    What is happening is as follows:

    In my FSVariables file I have the following entry which worked perfectly under FS2004.

    [LANDING_GEAR_HANDLE]
    Offset=0BE8
    Length=4
    FSType=Proportional
    LoValue=0
    HiValue=16383
    Format=###########
    Multiplier=1
    Divisor=1
    Integer=False
    WriteOnly=False

    Now using FSX and referencing the same FSVariables file, fs2phidgets shows the offset as INTL ... rather than displaying the offset 0BE8 in the offset column of the GUI interface. I do not know why ???

    The result is that when I operate the landing gear handle fs2phidgets shows the value going on/off depending whether I have the handle in the down or up position. That is working BUT the problem is that in FSX nothing happens with the gear. It remains in the same position regardless of the position of the hardware landing gear handle.

    I think this has something to do with the Offset column not showing the correct offset value as defined in the FSVariables file, that is instead of showing 0BE8 ... it shows "INTL"

    For other components I have attached to the 8/8/8 board fs2phidgets shows the correct offset value in the offset column for example for autobrake it show 2F80 which is correct and when I use the hardware autobrake switch, it works perfectly.

    I'm only having problems with the landing gear handle. Has anyone experienced this weird behaviour and have any suggestions?

    Thanks heaps in advance

    Cheers,
    Luke

  2. #2
    25+ Posting Member
    Join Date
    Apr 2007
    Location
    Australia
    Posts
    38
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Landing Gear Handle - Offset 0BE8 Problem - Not recognised


    Now using FSX and referencing the same FSVariables file, fs2phidgets shows the offset as INTL ... rather than displaying the offset 0BE8 in the offset column of the GUI interface. I do
    Hi all in my quote above I used INTL this is a typo. It should INTERN.

    I am still having the issue of 0BE8 offset being recognized as INTERN by fs2phidgets (as shown in the offset column of the fs2phidgets GUI) and as such when I operate my gear handle it does not function in FSX.

    I used this offset as defined in the included FSvariables.ini file successfully against FS2004 using 4.2.9

    Now than I'm using FSX and have upgraded to fs2phidgets 4.3.65 it does not work.


    Perhaps a bug with fs2phigets 4.3.65?

    I would appreciate any advice.

    Cheers
    Luke

  3. #3
    500+ This must be a daytime job



    Join Date
    Oct 2009
    Location
    Juneau, AK
    Posts
    615
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Landing Gear Handle - Offset 0BE8 Problem - Not recognised

    Do you still have a earlier version of fs2p? You could try that. I am using fs2p5 with no problems.
    http://juneaucessnasim.blogspot.com
    N58243 (virtual)- Low and Slow...

  4. #4
    25+ Posting Member
    Join Date
    Apr 2007
    Location
    Australia
    Posts
    38
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Landing Gear Handle - Offset 0BE8 Problem - Not recognised

    Quote Originally Posted by AK Mongo View Post
    Do you still have a earlier version of fs2p? You could try that. I am using fs2p5 with no problems.
    Hi,

    Thank you for your reply. Yes that was going to be my next attempt at a solution. I still have fs2phidgets 4.2.9 on another client that is connected to a 0/16/16 board so I will rewire my landing gear to that board and go via 4.2.9.

    I wonder if the problem exists in version 4.3.66 ? I am reluctant to try fs2phidgets 5 because the interface is so alien and I just want to get up and flying soon.

    Hopefully Alan may be able to shed some light on this problem?

    Thanks again for your suggestion.

    Cheers,
    Luke

  5. #5
    builder
    Join Date
    Jan 2007
    Location
    Texas
    Posts
    576
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Landing Gear Handle - Offset 0BE8 Problem - Not recognised

    4.3.66 fixes internal problem.

  6. #6
    25+ Posting Member
    Join Date
    Apr 2007
    Location
    Australia
    Posts
    38
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Landing Gear Handle - Offset 0BE8 Problem - Not recognised

    Quote Originally Posted by CocnutAir View Post
    4.3.66 fixes internal problem.

    Hi Alan,

    Thank you for your reply. I upgraded to 4.3.66 and I can confirm it works. Thank you again and thank you AK Mongo for your input as well.

    Cheers,
    Luke