Results 1 to 6 of 6
  1. #1
    25+ Posting Member
    Join Date
    Aug 2007
    Location
    SW Florida USA
    Posts
    73
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    FSphidgets only works with emulator

    Hi Alan:

    Have been setting up my LED-64 with the 4.3.66 version of Phidgets. For program testing I have been using the LED-64 emulator. The new user interface works very well and I had no problems programming all my LED functions (24 leds total)

    The program communicates with FSX with no problem. I have tested all the FSX functions with the led-64emulator and all work correctly.

    The problem occurs when I try to run an actual LED-64 board. The control panel Gui opens but all the functions show up as unassigned.

    When I remove the LED-64 card and re-start Phidgets the control panel Gui shows all my functions as programmed correctly.

    Also observed the following with led-64 board connected:

    1. TEST ALL LEDS button on FS2 Phidgets control panel does light all ledsPHidgets via LED64 card correctly.
    2. The led card 41038led is detected correctly on FS2 Phidgets control panel.
    3. The Phidgets manager will light individual LED64 card outputs correctly.
    4. I cannot light an individual led using the red individual led button on the FS2 Phidgets control panel.
    5. If I assign a function (e.g. landing gear nose) and click configure I get a
    RUNTIME ERROR METHOD~of object~failed

    System is I7-2600k,W7-64,8g ram, FSUIPC 4.811
    Phidgets is installed in C:/FS2PHIDGETS

    Phidgets version 4.3.65 updated to v4.3.66
    phidget21 v2.1.8 phidget21.net v2.1.8.91

    Regards

    Ken K
    Last edited by KenK; 03-27-2012 at 02:33 PM. Reason: add additional info

  2. #2
    builder
    Join Date
    Jan 2007
    Location
    Texas
    Posts
    587
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FSphidgets only works with emulator

    Ken,

    On initial start-up all components will be unassigned until you assign them.
    Where did assignments come from after you restarted Phidgets?
    Phidgets have no technology for anticipating your thoughts. I am confused.

    Single led test is problem. Workaround for that is to toggle "invert" setting.
    The error message in point 5 is a problem. I will try out my LEd-64 when I am home week-end after next.

    Regards,
    Alan

  3. #3
    25+ Posting Member
    Join Date
    Aug 2007
    Location
    SW Florida USA
    Posts
    73
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FSphidgets only works with emulator

    Hi Alan:

    When I start the Phidgets software the control panel comes up and in the upper left corner it says:

    serial device status --->shows green
    > 41038 led

    Below this in the column label it says:

    LED 41038 components


    I dont recall formally assigning it but maybe I did earlier. Tried re-boot and start Phidgets again

    It still says > 41038 led

    I will look at the INI. file maybe some clue there. Keep you posted.

    Regards Ken K
    Last edited by KenK; 03-29-2012 at 12:33 PM. Reason: add more inf

  4. #4
    builder
    Join Date
    Jan 2007
    Location
    Texas
    Posts
    587
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FSphidgets only works with emulator

    A screenshot might be helpful.
    Send screenshot to alan@coconutair.com
    You could also attach ini to email.

  5. #5
    25+ Posting Member
    Join Date
    Aug 2007
    Location
    SW Florida USA
    Posts
    73
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FSphidgets only works with emulator

    Hi Alan:

    I had to be out of town for a couple days also. Will send some screen shots and files next week.

    I also will check that all is in correct folder this is W7-64 so I have a couple places where I can incorrectly install it !!!

    Regards Ken K

  6. #6
    builder
    Join Date
    Jan 2007
    Location
    Texas
    Posts
    587
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FSphidgets only works with emulator

    Ken,

    Don't worry about screen shots, I am able to replicate problem on my system.
    The single test is redundant. I use the Phidget Manager on the tray to test connectivity.
    I use this to test circuitry after I have soldered leds.
    Only when I know I have wired up correctly do I fire up fs2phidget to assign to specific FS functions.

    Regards,
    Alan