Results 1 to 3 of 3
  1. #1
    300+ Forum Addict Tom_G_2010's Avatar
    Join Date
    Mar 2011
    Location
    Central Mass
    Posts
    437
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    FS2Phidget V4 is causing WideClient to crash ???

    Alan,

    I just started working with Fs2Phidget V4.3.66 after having decided to stop further use of V5. I also made the move to put FS2Phiddget on a second pc and connect via WideFS.

    Just yesterday I loaded the latest version of FSUIPC and added a registration for WideFS. I loaded the WideClient on the second PC. Yours is the first app I'm using via WideClient and my intial efforts are to drive some LEDs and Servos via an LED64 and Advanced Servo Controller.

    All went well yesterday, in fact great. FS2Phidget connected through WideFS/FSUIPC to FSX and worked well. After work today I went to resume my efforts and am running into a windows error with the WideClient app. It boots and connects right away as expected. But, within about 60 seconds of launching the FS2Phidget app, WideClient stops working and a windows error pops up stating "FS Eliminator for FSUIPC client application has stopped working".

    The only other app I have installed on my second pc at the moment that would take advantage of WideFS is a demo of one of the GA panels from Project Magenta. It seems to run fine WideClient stays up. It appears to only be when I load the FS2Phidget App that it crashes. As such it would appear that Fs2Phidget is the source of the problem. I've reached out to Pete Dowson as well in case he has seen this before and am awaiting his reply.

    Any idea what might be causing this or where I can look to resolve it?

    Thanks in advance!
    Tom G.

    I pulled the pertinent log files from FSUIPC and WideFS. Any chance there's a log file in F2SPhidget that might be helpful? OR, is there any logging functionality in Win 7 that might better capture the issue?

    Code:
    [Config]
    ButtonScanInterval=20
    ClassInstance=0
    NetworkTiming=5,1
    MailslotTiming=2000,1000
    PollInterval=2000
    Port=8002
    Port2=9002
    ResponseTime=18
    ApplicationDelay=0
    TCPcoalesce=No
    WaitForNewData=500
    MaxSendQ=100
    OnMaxSendQ=Log
    NewSendScanTime=50
    Priority=3,1,2
    [Sounds]
    Path=C:\WideClient\Sound\
    Device1=Primary Sound Driver
    Device2=Speakers / HP (IDT High Definition Audio CODEC)
    Device3=Headphones (RTC) (IDT High Definition Audio CODEC)
    Code:
    ********* WideClient Log [version 6.94] Class=FS98MAIN *********
    Date (dmy): 14/03/12, Time 20:25:56.241: Client name is TANDJTABLETPC
          219 LUA: "C:\WideClient\Initial.LUA": not found
          234 Attempting to connect now
         1248 Trying to locate server: Need details from Server Broadcast
         1248 Failed to connect: waiting to try again
         3261 Attempting to connect now
        13369 Server = HP410_KITCHENPC
        13385 Trying TCP/IP host "HP410_KITCHENPC" port 8002 ...
        13385 ... Okay, IP Address = 192.168.1.5
        13416 Connection made okay!
        18049 New Client Application: "FS2Phidget" (Id=1068)
    Code:
    ********* WideServer.DLL Log [version 7.81] *********
    Blocksize guide = 8192 (double allowed)
    Date (dmy): 14/03/12, Time 20:25:51.073: Server name is HP410_KITCHENPC
        15631 Initialising TCP/IP server
        15631 Initialising UDP/IP server
        16130 Broadcasting service every 1000 mSecs
        16707 Incoming connection Accepted ok (skt=11412) TCP
        17066 Connected to computer "TANDJTABLETPC" running WideClient version 6.940 (skt=11412) TCP
        47143 Restarting service due to zero reception!
        89576 Closing down now ...
    Memory managed:  Offset records: 129 alloc, 128 free
    Read buffer usage:  11 alloc, 11 free, max in session: 1
    Write buffer usage: 1172 alloc, 1172 free, max in session: 1
    Throughput maximum achieved:  19 frames/sec, 640 bytes/sec
    Throughput average achieved for complete session:  3 frames/sec, 91 bytes/sec
    Average receive rate from "TANDJTABLETPC":  0 frames/sec, 6 bytes/sec
    ********* Log file closed *********
    Code:
    ********* FSUIPC4, Version 4.81 by Pete Dowson *********
    User Name="Xxx Xxxxxx"
    User Addr="xxx@xxxxxxxxxx.xxx"
    FSUIPC4 Key is provided
    WideFS7 Key is provided
    Running inside FSX on Windows 7
    Module base=61000000
          764 System time = 14/03/2012 20:24:44
          780 FLT UNC path = "\\HP410_KITCHENPC\Users\Flight Sim\Documents\Flight Simulator X Files\"
          827 Trying to connect to SimConnect Acc/SP2 Oct07 ...
          827 FS UNC path = "C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\"
         1264 LogOptions=00000000 00000001
         1264 Wind smoothing fix is fully installed
         1264 G3D.DLL fix attempt installed ok
         1264 SimConnect_Open succeeded: waiting to check version okay
         1264 Trying to use SimConnect Acc/SP2 Oct07
         5429 Running in "Microsoft Flight Simulator X", Version: 10.0.61637.0 (SimConnect: 10.0.61259.0)
         5429 Initialising SimConnect data requests now
         5429 FSUIPC Menu entry added
         5491 \\HP410_KITCHENPC\Users\Flight Sim\Documents\Flight Simulator X Files\KTRG BONANZA.FLT
         5491 C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\SimObjects\Airplanes\Carenado BONANZA V35B\Carenado_V35.AIR
         6880 Weather Mode now = Global
        24289 C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\SimObjects\Airplanes\C172\Cessna172SP.AIR
        52401 Aircraft="Cessna Skyhawk 172SP Paint2"
        52416 System time = 14/03/2012 20:25:35, Simulator time = 20:24:48 (01:24Z)
        67689 Starting everything now ...
        67720 Advanced Weather Interface Enabled
        75177 Weather Mode now = Theme
        75614 Weather Mode now = Global
       144972 Sim stopped: average frame rate for last 81 secs = 20.8 fps
       159620 System time = 14/03/2012 20:27:23, Simulator time = 20:26:09 (01:26Z)
       159620 *** FSUIPC log file being closed
    Average frame rate for running time of 82 secs = 20.8 fps
    G3D fix: Passes 15694, Null pointers 0, Bad pointers 0, Separate instances 0
    Memory managed: 129 Allocs, 129 Freed
    ********* FSUIPC Log file closed ***********
    https://www.facebook.com/mycessnasim PC: Intel Core i7 Haswell @ 3.8GHz, 8Gb Ram, Win 7 64Bit, dual SSDs, GeFroce 780 SIM: FSX w/Aclrtn Pk, FSUIPC4, ASN, UTX, GEX, REX 4

  2. #2
    300+ Forum Addict Tom_G_2010's Avatar
    Join Date
    Mar 2011
    Location
    Central Mass
    Posts
    437
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FS2Phidget V4 is causing WideClient to crash ???

    Alan,

    I've been corresponding with Pete Dowson over on the simflight forum and he has found what he believes is triggering the problem. We may have a work around but I have not yet fully tested it. I'm hoping to do so this weekend. However, it's still a workaround and it would be far better to get to the root cause and resolve it.

    After he studied the WideFS logs and the Windows error log from my pc's he found that the crash is actually occurring in DINPUT.DLL, which is the DirectInput part of Windows. WideClient uses that to scan for buttons to be sent to FS.

    Although it should not matter which is launched first, the more typical sequence would be to launch WideClient and then FSX/WideServer. The crash occurs when it's done the other way around. Pete explained that Client first Server second would be the more conventional sequence. And, when done that way WideClient does not crash. However, I have not yet tested to see if it will still pass button presses and remain stable. I'll be doing that this weekend and will share the results.

    He asked if Phidgets boards look like a Direct Input device or have a Dinput driver. I am hoping you can help in answering that. This weekend I'll be doing some housekeeping on the pc that is presently running FS2Phidgets and WideClient to ensure there are no file conflicts or corruption. After that I'll be testing some button inputs to see if they function properly.

    Any additional information or assistance you can provide would be greatly appreciated!!!

    Thanks!
    Tom G.
    https://www.facebook.com/mycessnasim PC: Intel Core i7 Haswell @ 3.8GHz, 8Gb Ram, Win 7 64Bit, dual SSDs, GeFroce 780 SIM: FSX w/Aclrtn Pk, FSUIPC4, ASN, UTX, GEX, REX 4

  3. #3
    builder
    Join Date
    Jan 2007
    Location
    Texas
    Posts
    587
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FS2Phidget V4 is causing WideClient to crash ???

    Tom,

    Phidgets do not emulate or utilize DirectX / DirectInput.

    fyionly at this point: FS2Phidget.log file is in the directory where you installed Fs2Phidget.


    Regards,
    Alan


    Quote Originally Posted by Tom_G_2010 View Post
    Alan,

    I've been corresponding with Pete Dowson over on the simflight forum and he has found what he believes is triggering the problem. We may have a work around but I have not yet fully tested it. I'm hoping to do so this weekend. However, it's still a workaround and it would be far better to get to the root cause and resolve it.

    After he studied the WideFS logs and the Windows error log from my pc's he found that the crash is actually occurring in DINPUT.DLL, which is the DirectInput part of Windows. WideClient uses that to scan for buttons to be sent to FS.

    Although it should not matter which is launched first, the more typical sequence would be to launch WideClient and then FSX/WideServer. The crash occurs when it's done the other way around. Pete explained that Client first Server second would be the more conventional sequence. And, when done that way WideClient does not crash. However, I have not yet tested to see if it will still pass button presses and remain stable. I'll be doing that this weekend and will share the results.

    He asked if Phidgets boards look like a Direct Input device or have a Dinput driver. I am hoping you can help in answering that. This weekend I'll be doing some housekeeping on the pc that is presently running FS2Phidgets and WideClient to ensure there are no file conflicts or corruption. After that I'll be testing some button inputs to see if they function properly.

    Any additional information or assistance you can provide would be greatly appreciated!!!

    Thanks!
    Tom G.