Results 1 to 6 of 6
  1. #1
    150+ Forum Groupie twisted8's Avatar
    Join Date
    Jun 2009
    Location
    California
    Posts
    243
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Having trouble with SIOC V4.0 and lekseecon FMC code

    Hello,

    I just upgraded to the SIOC v4 and when I export my old sioc script i have a problem this line for the FMC:

    IF &Key != 0

    it turns into IF &Key 0 which doesn't import. I can manually change it back and it imports ok but the fmc doesn't work anymore

    IF &Key <> 0 seems to import ok but my FMC keys still don't work. The USB_Key card is working properly and i can see the keys ok.

    Any suggestions?

    thanks!

  2. #2
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,202
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Having trouble with SIOC V4.0 and lekseecon FMC code

    Hi,

    [Tip: Never use Export to .txt. Always keep control over your own script... Make it with the Notepad editor and compile it with config_sioc.exe.]

    My FMC script (with IF &Key != 0 ) compiled okay and worked fine with the beta version of SIOC 4.0. I'm at work now, but will test it this evening with the new SIOC 4.0 released version. [EDIT in the evening: RESULT OK!]

    Could you post you lekseecon_log.txt, sioc.ini and your FMC script (the one you compiled).

    regards,
    Nico
    Last edited by kiek; 09-29-2011 at 12:57 PM.

  3. #3
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,202
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Having trouble with SIOC V4.0 and lekseecon FMC code

    Hi twisted8,
    You do not seem to react. Problem gone?

    I will delete this thread one day from now, because this is of not much use for (future) readers.

    Regards,
    Nico

  4. #4
    150+ Forum Groupie twisted8's Avatar
    Join Date
    Jun 2009
    Location
    California
    Posts
    243
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Having trouble with SIOC V4.0 and lekseecon FMC code

    Hello,
    sorry for the delay. I have been away from my sim.
    [Edit]
    I finally figured out the problem was the device ID for the iokeys card in the SIOC script was wrong. I think my USB configurations changed so probably nothing to do with the v4. Removing the device ID from the SIOC script worked good
    Thank you
    also for anybody out there that also makes the mistake of exporting the script to txt the line with IF &Key != 0 needs to be updated since the != gets deleted.

  5. #5
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,202
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Having trouble with SIOC V4.0 and lekseecon FMC code

    Hello,
    Good to hear you again, and that your problem was solved.

    To me it looked like you have lost your sioc.ini while upgrading to SIOC version 4.0.
    In sioc ini you will find a line like this:

    USBKeys=x,87

    that should correspond to this SIOC line in your FMC script:

    Var 6000 Static name Key Link USB_KEYS Device x

    x in your code must be the same as x in sioc.ini. If you remove Device x at all you have defined it to be 0 (default).

    I also recommend to shorten your sioc.ini. You have lots of useless definitions in there. Have a look at mine here.

    regards,
    Nico
    Last edited by kiek; 10-05-2011 at 03:43 PM.

  6. #6
    150+ Forum Groupie twisted8's Avatar
    Join Date
    Jun 2009
    Location
    California
    Posts
    243
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Having trouble with SIOC V4.0 and lekseecon FMC code

    that's exactly what the problem was
    Var 6000 Static name Key Link USB_KEYS Device x
    I removed the device to deafult to 0 and it works good now. It used to be device 2.
    Good suggestion I will try to clean up the ini file. Thanks for the info!