Results 1 to 5 of 5
  1. #1
    75+ Posting Member Stijn's Avatar
    Join Date
    Aug 2008
    Location
    Netherlands
    Posts
    85
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Question Radio Altimeter SIOC script doesn't work Help!!

    Hi there,

    After succesfully interfacing a real VSI (tutorial will be posted soon!!!!) I like to do the same with a radar altimeter.

    Ok, found the offset but still got a problem with the script.:
    why doesn't this work?


    Var 0000, Value 0 // - Initialization
    {
    V0001 = 1022
    }

    Var 0001, Link USB_SERVOS, Output 1, PosL 170, PosC 511, PosR 1022, Type 1 // Radar Altimeter

    Var 0010, name RaltOffst, Link FSUIPC_IN, Offset $31E4, Length 4 // Radar Altimeter
    {
    L0 = &RaltOffst / 19975.3721 // FSUIPC conversion (65536 = 1 Meter --> 19975.3721 = 1 foot)
    L1 = L0 * 0.852 // 1000 feet = 852 positions
    L2 = 1021 - L1
    &RaltOffst = L2
    }



    Thanks,

    Stijn
    Last edited by Stijn; 08-23-2011 at 08:17 PM. Reason: improvement

  2. #2
    500+ This must be a daytime job 737NUT's Avatar
    Join Date
    Feb 2006
    Location
    Indianapolis, IN
    Posts
    778
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Radio Altimeter SIOC script doesn't work Help!!

    Whats showing up in IOCP console? Anything at all?

  3. #3
    75+ Posting Member Stijn's Avatar
    Join Date
    Aug 2008
    Location
    Netherlands
    Posts
    85
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Radio Altimeter SIOC script doesn't work Help!!

    By that you mean what's in the IOCP server box right?

    It says: port 8092 and 1 Clients connected

    is this what you mean.
    because the script should work right?

    oh, when loading the script for the VSI the gauge works

    Stijn

  4. #4
    75+ Posting Member
    Join Date
    Apr 2009
    Location
    Toronto
    Posts
    125
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Radio Altimeter SIOC script doesn't work Help!!

    Stijn,

    &RaltOffst = L2

    should be

    V0001 = L2

    Jim.

  5. Thanks Stijn thanked for this post
  6. #5
    75+ Posting Member Stijn's Avatar
    Join Date
    Aug 2008
    Location
    Netherlands
    Posts
    85
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Radio Altimeter SIOC script Help!!

    Thanks Jim,

    Works great


    Stijn

Tags for this Thread