Results 1 to 9 of 9
  1. #1
    300+ Forum Addict Tom_G_2010's Avatar
    Join Date
    Mar 2011
    Location
    Central Mass
    Posts
    437
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Question FS2Phidget won't recognize .NET 4 ???

    I am in the process of making a decision on what I/O cards to use for my pit build. The list has narrowed and Phidgets cards are fast rising to the top.

    I decided I wanted to look at the FS2Phidget App as part of my evaluation. However, when I try to load it I keep getting the warning that says I need to be running the .NET framework and it stops the install.

    I'm running Win 7 64bit on an I5 processor and have .NET 4 loaded. I ran a reload of .NET 4 to be sure it was installed properly. Does FS2Phidget need to see an older release of .NET framework?

  2. #2
    500+ This must be a daytime job



    Join Date
    Oct 2009
    Location
    Juneau, AK
    Posts
    619
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FS2Phidget won't recognize .NET 4 ???

    Quote Originally Posted by Tom_G_2010 View Post
    I am in the process of making a decision on what I/O cards to use for my pit build. The list has narrowed and Phidgets cards are fast rising to the top.

    I decided I wanted to look at the FS2Phidget App as part of my evaluation. However, when I try to load it I keep getting the warning that says I need to be running the .NET framework and it stops the install.

    I'm running Win 7 64bit on an I5 processor and have .NET 4 loaded. I ran a reload of .NET 4 to be sure it was installed properly. Does FS2Phidget need to see an older release of .NET framework?
    Not sure, but I can share my warning panel file I created in FS2Ph if you need an example of how it works when you get it running.

    Reid
    http://juneaucessnasim.blogspot.com
    N58243 (virtual)- Low and Slow...

  3. #3
    300+ Forum Addict Tom_G_2010's Avatar
    Join Date
    Mar 2011
    Location
    Central Mass
    Posts
    437
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FS2Phidget won't recognize .NET 4 ???

    That would be much appreciated!!! Nothing is better than a live tested working example.

    I may have found the answer to the .NET 4 issue. I think FS2P needs .NET 1.1 specifically. And I found that .NET framework releases can run side by side. Each newer version isn't necessarily a replacement of the prior version like other apps.

    So I'm downloading 1.1 now, BIG file so it may take a bit.

    Thanks for the offer of the example setup!

  4. #4
    500+ This must be a daytime job



    Join Date
    Oct 2009
    Location
    Juneau, AK
    Posts
    619
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FS2Phidget won't recognize .NET 4 ???

    No Problem!

    Just PM me your email address, and I will send it on.

    Reid
    http://juneaucessnasim.blogspot.com
    N58243 (virtual)- Low and Slow...

  5. #5
    300+ Forum Addict Tom_G_2010's Avatar
    Join Date
    Mar 2011
    Location
    Central Mass
    Posts
    437
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FS2Phidget won't recognize .NET 4 ???

    Installed .NET 1.1. I received a Win 7 compatibility warning about 1.1 but proceeded anyway. FS2P now loads and runs. As soon as next months pay check comes in I think I'll be buying a board and some LEDs to start experimenting.

  6. #6
    500+ This must be a daytime job



    Join Date
    Oct 2009
    Location
    Juneau, AK
    Posts
    619
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FS2Phidget won't recognize .NET 4 ???

    Make sure you get the connectors for wiring the board. They use little plugs to interface. If I were to do it again, I may have gotten the pre built wire leads with connectors attached. I got my card from ebay and it was missing the connectors and it involved a lot of soldering and fiddling to make it work right.

    Reid
    http://juneaucessnasim.blogspot.com
    N58243 (virtual)- Low and Slow...

  7. #7
    builder
    Join Date
    Jan 2007
    Location
    Texas
    Posts
    587
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FS2Phidget won't recognize .NET 4 ???

    To avoid compatibility warning run as administrator.
    Right-click on desktop shortcut and select "Run as administrator".

    I am making some changes to Fs2Ph4.
    Feedback I am getting for users indicates this is preferred version.

    Releasing version beta next week after July 4th.
    Quick update on changes to date.

    Fs Variables:
    No separate FsVariable Editor.

    FsVariable Editor button on FS2Phidget screen.

    Function FsVariables - Addition, Subtraction, Multiplication and Division operations.

    Logic Variables - all logical operators supported.
    Logic Variables - Use constants in logical expressions.

    Text FsVariable type - used for offsets containing text e.g. VOR names.

    Improved editing of Discrete FsVariables.

    User-Defined "internal" FsVariables - these are FSVariables that do not have an FSUIPC offset.

    "Circuits" are being replaced by "Variable Groups, another type of FsVariable.

    Push-to-Test, Push-To-Reset, Push-To-Recall implemented as FsVariables.

    New Phidgets:
    Support for Analog Ouput.

    Configuration:
    Analog Input configuration is now a wizard.
    LED64 Brightness determined by FsVariable.

    Hardware Tests:
    Test Leds and LCDs without enabling components.
    Single test for Digital Outputs is redundant - discontinued.

    Regards,
    Alan
    Last edited by CocnutAir; 06-30-2011 at 02:12 AM.

  8. Thanks Matt Olieman thanked for this post
  9. #8
    300+ Forum Addict Tom_G_2010's Avatar
    Join Date
    Mar 2011
    Location
    Central Mass
    Posts
    437
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FS2Phidget won't recognize .NET 4 ???

    Alan,

    Thanks for the detailed response and your support. I'll be watching for the new release.

  10. #9
    10+ Posting Member Mickey_Techy's Avatar
    Join Date
    Mar 2012
    Location
    India
    Posts
    21
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FS2Phidget won't recognize .NET 4 ???

    Quote Originally Posted by Tom_G_2010 View Post
    Installed .NET 1.1. I received a Win 7 compatibility warning about 1.1 but proceeded anyway.....
    Following your experience, I decided to ignore the compatibility warning and proceed with the install anyway, but it doesn't work for me. The install proceeds for a little bit, and then unwinds.

    Without having 1.1 installed I can't install FS2Ph. Kinda stuck now.

    Can anyone advice please.
    Mickey 'AviaScorp' Sharma
    My Pit blog at http://aviascorpmusing.blogspot.in/