Results 1 to 5 of 5
  1. #1
    500+ This must be a daytime job Boeing 747 Flyer's Avatar
    Join Date
    Nov 2009
    Location
    England
    Posts
    771
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Saitek Radios - Annoying Problem

    Hi everyone,

    Simply put, my Saitek Radios do NOT work.

    I have 2, and they have been okay for almost 2 years. For the past 3 months however... Well, they have been, what can only be described as, a failure.

    This is what happens. I start FSX and the modules are plugged in properly.

    After FSX has loaded, all COM frequencies reset to 118.00, and all NAV frequencies set to 108.00. Weird, but nonetheless, this is only the root of the issue.

    Basically, I tune my STANDBY frequency. I then press the frequency switch button. My frequency switches, but then 2 seconds later, it resets to 118.00.

    Same with the NAV radios, but they reset to 108.00.

    A step-by-step of what happens:

    1.) Tune STANDBY frequency (129.23)

    2.) Switch frequencies

    3.) 118.00 changes to 129.23 as I want.

    4.) 2 seconds later, it pings back to 118.00

    You may think it is the standby switch getting stuck.. Not at all, it works fine; I have even tested it using the SPAD software.

    Also, changing the frequency in FSX is impossible too. Say I tune a frequency of 125.43 with my MOUSE, it pings back to 118.00.

    I really have had it with these Saitek problems. Recently, my Yoke blew due to a horrifically poor design of a PCB circuit. Also, they do not seem to answer emails.

    Regards,

    Jack

    EDIT: Haha! As a further insult, Saitek have prevented anyone from registering on their "support" forum. World class support heh?

  2. #2
    25+ Posting Member
    Join Date
    Apr 2009
    Location
    South Carolina
    Posts
    71
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Saitek Radios - Annoying Problem

    I'm sure this isn't the answer you're looking for but I redo my system once a year. I use my computer for just about everything. I've removed programs i don't like. have "updated everything several times. Have defraged and cleaned up every week for that entire year. there comes a point when it's its time for a spring cleaning. I have an extra ghost disk that I made a few years ago with all my normal "stuff" on it (Windows and all my FSX programs) . I ghost it back over to my main drive and do a few hours of updates to bring it up to date. Everything is faster opening and loading. The FPS's even increase. I find this process is much easier than trying to troubleshoot some phantom issue that pops up out of nowhere.
    John

  3. #3
    150+ Forum Groupie
    Join Date
    Oct 2010
    Location
    Australia
    Posts
    166
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Saitek Radios - Annoying Problem

    Hi,

    Just a thought, what happens if you disconnect the Saitek Radios and change the frequencies in FSX, do they revert back to the 118 and 108 still. If so, then it can't be the Saitek Radios. Have you tried this?.

    Kind Regards

    Bernie.
    E8400 @ 3.0GHz, DDR2 Ram 800MHz 4Gb, Vista Home Premium 64Bit, MSI 9800GT @ 512Mb, Philips 22" LCD Widescreen, Cockpit Setup X 5 using Wideview and Widetraffic.

  4. #4
    500+ This must be a daytime job Boeing 747 Flyer's Avatar
    Join Date
    Nov 2009
    Location
    England
    Posts
    771
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Saitek Radios - Annoying Problem

    Quote Originally Posted by Bernie View Post
    Hi,

    Just a thought, what happens if you disconnect the Saitek Radios and change the frequencies in FSX, do they revert back to the 118 and 108 still. If so, then it can't be the Saitek Radios. Have you tried this?.

    Kind Regards

    Bernie.
    Hi Bernie,

    Thanks for the reply. It has turned out that the problem was the Opencockpits IOCModules software. For some reason, it forces all frequencies to 118.00. Luckily, I managed to disable it whilst still being able to use the software.

    Jack

  5. #5
    New Member
    Join Date
    Jun 2011
    Location
    Texas
    Posts
    1
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Saitek Radios - Annoying Problem

    Hello

    I am a new member but after reading your problem I too am having the same problem. I have tried disconnecting the Saitek Radio Panel and still have the problem. Where do I look for what may be causing this error and how did you find the solution. HELP !!!

    It appears that the Nav Radios just cycle from 108 - 118 and no further. Also have a similiar cycling on the Com radios. I an really at a loss. I don't know what was loaded and when the proble occurred as I am just getting into Vor to Vor and using the Nav radios when I found out I could not dial in a NDB RQM 221.0

    Ron
    Last edited by Buffaloron; 06-23-2011 at 05:50 PM. Reason: New Info