Results 1 to 7 of 7

Thread: Lekseecon 7.2

  1. #1
    150+ Forum Groupie


    Perik's Avatar
    Join Date
    Aug 2007
    Location
    NORWAY
    Posts
    229
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Lekseecon 7.2

    Hi Nico

    I may be wrong, but have you done any changes to the Refresh
    Variable range (989-999) and how the trigger behaves?
    Version 7.0 is OK and I get my code executed, but 7.2 no action at all.
    Regards,
    Per-Erik
    www.hoddo.net

  2. #2
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,202
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Lekseecon 7.2

    No changes at all...
    You should search and find your problem elsewhere...
    Check your lekseecon_log.txt file
    Last edited by kiek; 03-22-2011 at 04:50 PM.

  3. #3
    150+ Forum Groupie


    Perik's Avatar
    Join Date
    Aug 2007
    Location
    NORWAY
    Posts
    229
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Lekseecon 7.2

    Nico

    Lekseecon 7.0 don't have the nice logging features as V 7.2
    so this section is from the latter and shows the MIP light test firing
    and the following action of Buttons lights but no execution
    of 989-999 vars where my Display Calls are.
    IOCP-Console shows about the same.

    (580) MIP Lights Test = 1
    (740) vor1_mode = -1 ->S
    (741) vor2_mode = -1 ->S
    (742) MCP_buttons_lights = -1 ->S
    (766) alternate gear = -1 ->S
    (856) autoland = -1 ->S
    S-> (580) MIP Lights Test = 0
    (740) vor1_mode = 6 ->S
    (741) vor2_mode = 6 ->S
    (742) MCP_buttons_lights = 194 ->S
    (766) alternate gear = 0 ->S
    (856) autoland = 0 ->S
    Tue Mar 22 21:54:06 2011
    I'm running the same SIOC code in both tests - just changing Lekseecon from 7.0 to 7.2.
    Regards,
    Per-Erik
    www.hoddo.net

  4. #4
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,202
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Lekseecon 7.2

    Hi Perik,
    Please post your lekseecon_log.txt to see whether vars 989-999 were recognised by lekseecon ...

    Regards,
    Nico

  5. #5
    150+ Forum Groupie


    Perik's Avatar
    Join Date
    Aug 2007
    Location
    NORWAY
    Posts
    229
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Lekseecon 7.2

    Hello Nico,

    Attached a few files (zip) containing the code +++ I'm running for a simplified
    setup. Consist of three modules all taken from your cockpit767 catalog:

    3.2_Vor1.txt, 6.1_ColdAndDark.txt and 6.2_TestLightsMIP.txt
    These are only modified with my own device-numbering.

    An extract from Lekseecon log:
    Number of lekseecon variable(-s) detected: 7
    267 268 270 580 740 782 989
    The remaining is attached and I hope this will give some information.
    Remember - the only thing I change between the two runs is Lekseecon 7.0 <-> 7.2
    Attached Files Attached Files
    Regards,
    Per-Erik
    www.hoddo.net

  6. #6
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,202
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Lekseecon 7.2

    Hello Perik,
    Thank you for your elaborate test suite and congratulations: you have found a bug! I could reproduce it at my site.
    I also found out that this bug (that slipped in...) was already solved by a 7.3 version I was working on over the last 2 months so, please be patient, in a few weeks I'll release 7.3 and it will be fixed.

    Regards,
    Nico

  7. #7
    150+ Forum Groupie


    Perik's Avatar
    Join Date
    Aug 2007
    Location
    NORWAY
    Posts
    229
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Lekseecon 7.2

    Nico,

    I'm glad I can help "cleaning" this great piece of code.
    Lekseecon will be part of my life for many years to come, so it's best
    the bugs are gone before my own "bugs" starts to show up

    At least I need to trust the Autopilot code

    Thanks for all your hard work!!
    Regards,
    Per-Erik
    www.hoddo.net

Similar Threads

  1. Lekseecon does not self extract exactly
    By jfh2007 in forum lekseecon Q&A and Discussions
    Replies: 4
    Last Post: 06-05-2010, 10:44 AM
  2. Lekseecon isn't working
    By Boeing 747 Flyer in forum lekseecon Q&A and Discussions
    Replies: 28
    Last Post: 05-09-2010, 08:33 AM
  3. Lekseecon error#3 lekseecon.ini not found
    By bsv118 in forum OpenCockpits General Discussion
    Replies: 3
    Last Post: 05-11-2009, 03:56 AM
  4. lekseecon v2.5 available
    By kiek in forum I/O Interfacing Hardware and Software
    Replies: 2
    Last Post: 10-18-2008, 08:50 AM
  5. LEKSEECON 2.0 available
    By kiek in forum I/O Interfacing Hardware and Software
    Replies: 1
    Last Post: 01-23-2008, 12:41 PM