Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1
    Our new friend needs to reach 10 posts to get to the next flight level
    Join Date
    Oct 2009
    Location
    Athens, Greece
    Posts
    7
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Unhappy Error #11 trying to run latest version.

    Hi guys,

    When trying to start the latest version of lekseecon I get an
    error #11 that the LevelD SDK version is not 2.02 or Lekseecon is not running on the FS PC.
    I double-checked the Lvldsdk.dll and confirmed it's v1.3.
    Also the Lekseecon is indeed running on the same PC as FS.
    What else can be wrong?

    Any help appreciated.
    Thanks!
    George

    Here's the Log:
    Code:
    Copyright (c) 2007-2010 Nico W. Kaan
    
    Prog: lekseecon9 version 6.0
      PC: DEATHSTAR E:\Flight Simulator Applications\lekseecon
      PF: C:\Program Files (x86)
    PF86: C:\Program Files (x86)
    
    lekseecon9.ini found:
    HOSTADDRESS=192.168.1.4
    PORT=8092
    CONFIG_FILE=z:\GD767.ssi
    
    132 LevelD767 Vars were detected in your CONFIG_FILE:
     275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294
     295 296 297 298 299 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401
     403 404 405 406 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423
     424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443
     444 445 446 447 448 449 450 451 452 453 454 455 510 511 515 516 517 518 527 528
     529 530 531 532 533 534 535 536 537 538 540 541 542 564 565 569 570 571 572 580
     742 771 776 777 778 779 782 819 820 821 822 962
    
    SIOC connected.
    Connecting to SDK Error 11: Level-D SDK is not version 2.02, or
    Lekseecon is not running at your flightsim PC ...
    
    lekseecon9 stopped.

  2. #2
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,198
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Error #11 trying to run latest version.

    Hello George,

    Three questions first, before looking into your problem:

    * what is the full path name to your ../IOCARDS/SIOC folder ?
    * are you running SIOC from your FS pc as well?
    * have you installed SIOC 3.7 beta1?

    regards,
    Nico

  3. #3
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,198
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Error #11 trying to run latest version.

    Quote Originally Posted by gdorkofikis View Post
    I double-checked the Lvldsdk.dll and confirmed it's v1.3.
    You should check that the Level-D 767 aircraft add on version is 1.3 (not the LVLDSDK.DLL), you can check that in the About box of the 767 in FS9

    Nico

  4. #4
    Our new friend needs to reach 10 posts to get to the next flight level
    Join Date
    Oct 2009
    Location
    Athens, Greece
    Posts
    7
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Exclamation Re: Error #11 trying to run latest version.

    Quote Originally Posted by kiek View Post
    Hello George,

    Three questions first, before looking into your problem:

    * what is the full path name to your ../IOCARDS/SIOC folder ?
    * are you running SIOC from your FS pc as well?
    * have you installed SIOC 3.7 beta1?

    regards,
    Nico
    Hi Nico,
    - SIOC 3.7 B1 is installed and running on a Laptop on the LAN with static IP.
    - It's not on the same PC running FS.
    - IOCPServer is installed in the modules of FS9.
    - On the laptop, SIOC is installed at d:\C O C K P I T\IOCards\SIOC.
    This particular folder is shared as "SIOC" with full access to everyone on the
    home network. Mapped as Z: on the main FS PC.

    - The LevelD B767 is reporting version 1.3 indeed.

    A few more info:
    - OS : Windows 7 Home Premium 64Bit with all latest drivers.
    - FS : FS9.1 updated and installed on a separate HDD (E:/FS2004)
    - 767: Downloaded and re-installed from scratch from the Flight1 wrapper.
    - The LvlDSDK.dll that is installed in the "Level D Simulations\SDK" folder DIFFERS from the LvlDSDK.dll that is included in the Lekseecon setup. Anyway I have trying every possible combination and still get the same error.
    - I have confirmed that the FS9 path is set the registry using the FS9RegUtility from FSTweaks (as it was destroyed when un-installed FSX). If you read from a specific registry location, let me know to check that it is correctly there. If not, that could be the problem.

    Regards,
    George

  5. #5
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,198
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Error #11 trying to run latest version.

    Quote Originally Posted by gdorkofikis View Post
    - IOCPServer is installed in the modules of FS9
    Your SIOC installation is ok, lekseecon9 is able to connect. Hoewever, there is (for lekseecon) really no need to install an IOCPserver in FS9 modules. Lekseecon talks to the IOCP server that is contained within SIOC.exe running at your laptop (not to an IOCPserver connected to FS9). I recommend to rermove it. (just to keep things simple).

    Quote Originally Posted by gdorkofikis View Post
    - The LvlDSDK.dll that is installed in the "Level D Simulations\SDK" folder DIFFERS from the LvlDSDK.dll that is included in the Lekseecon setup.
    This is not relevant. Lekseecon works with its own copy of the LVLDSDK.DLL which is in the leksecon folder. It is installed as part the lekseecon software package. lekseecon does not use the LVLDSDK.DLL from the Level D Simulations\SDK folder. I hope you have not replaced the file in the lekseecon folder.. If so you better re-install the lekseecon 6.0 software package (which is no big deal, you can just install it again, it will automatically remove the current version).

    I know that my error message 11 is confusing. I'll change that in a later version. It means that the SDK in the Level-D 767 add on is not the correct version (presumably caused by the wrong level-D 767 version). It does not mean that the LVLDSD.DLL has the wrong version... Since it is packed together with lekseecon that version is always ok. Furthermore , for clarification, the LVLDSDK.dll is not the SDK itself, but a dynamic link library with functions that communicate with the SDK in the Level-D 767 add-on. As soon as lekseecon starts, it links this library and tries to connect to the SDK.


    Quote Originally Posted by gdorkofikis View Post
    - I have confirmed that the FS9 path is set the registry using the FS9RegUtility from FSTweaks (as it was destroyed when un-installed FSX). If you read from a specific registry location, let me know to check that it is correctly there. If not, that could be the problem.
    ... oops registry tweaking is dangerious ...
    Lekseecon does not read information from the registry, but the LVLDSDK.DLL might do so, don't know.
    If I understand you well, you did no fresh install of FS9, right? If so, I believe it is much beter to do a fresh install, and then a fresh install of the Level-D 767 for FS9 up to version 1.3.


    regards,
    Nico
    Last edited by kiek; 07-28-2010 at 12:44 PM.

  6. #6
    Our new friend needs to reach 10 posts to get to the next flight level
    Join Date
    Oct 2009
    Location
    Athens, Greece
    Posts
    7
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Error #11 trying to run latest version.

    Quote Originally Posted by kiek View Post
    Your SIOC installation is ok, lekseecon9 is able to connect. Hoewever, there is (for lekseecon) really no need to install an IOCPserver in FS9 modules. Lekseecon talks to the IOCP server that is contained within SIOC.exe running at your laptop (not to an IOCPserver connected to FS9). I recommend to rermove it. (just to keep things simple).
    Ok, so no need for IOCPServer in the modules. Will remove it then.

    Quote Originally Posted by kiek View Post
    This is not relevant. Lekseecon works with its own copy of the LVLDSDK.DLL which is in the leksecon folder. It is installed as part the lekseecon software package. lekseecon does not use the LVLDSDK.DLL from the Level D Simulations\SDK folder. I hope you have not replaced the file in the lekseecon folder.. If so you better re-install the lekseecon 6.0 software package (which is no big deal, you can just install it again, it will automatically remove the current version).
    I figured it out this could be the case. I remember trying all combinations, including copying the lvldsdk.dll FROM Lekseecon TO the 767 sdk folder. Nothing works...

    Quote Originally Posted by kiek View Post
    I know that my error message 11 is confusing. I'll change that in a later version. It means that the SDK in the Level-D 767 add on is not the correct version (presumably caused by the wrong level-D 767 version). It does not mean that the LVLDSD.DLL has the wrong version... Since it is packed together with lekseecon that version is always ok. Furthermore , for clarification, the LVLDSDK.dll is not the SDK itself, but a dynamic link library with functions that communicate with the SDK in the Level-D 767 add-on. As soon as lekseecon starts, it links this library and tries to connect to the SDK.

    ... oops registry tweaking is dangerious ...
    Lekseecon does not read information from the registry, but the LVLDSDK.DLL might do so, don't know.
    If I understand you well, you did no fresh install of FS9, right? If so, I believe it is much beter to do a fresh install, and then a fresh install of the Level-D 767 for FS9 up to version 1.3.
    Ok. But I'm still confused.
    The FS is at the same PC, freshly installed (so registry is correct), followed by a fresh install for LevelD 767 using the CURRENT wrapper file at Flight1. I re-downloaded it and installed it from there. NO copy from older installation except the panel.cfg which I don't think has anything to do with it.
    The version reported by the LevelD 767 IS 1.3 as you can see here:
    LevelDVersion.jpg
    The DLL version in the LevelD Simulations\LevelD SDK folder
    LevelDSDK of 767 version.jpg
    The DLL Version that comes with Lekseecon
    LevelDSDK of Lekseecon Version.jpg

    So, either something is indeed wrong version, or the way to confirm that is wrong.
    How do you see if FS IS installed on the same PC ?

    Cheers,
    George
    PS. You can go technical if you like. I am a programmer myself after all.
    Last edited by gdorkofikis; 07-28-2010 at 05:19 PM. Reason: Added Screenshots

  7. #7
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,198
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Error #11 trying to run latest version.

    Hi George,
    It's getting very strange .. all seems ok. But it still does not work for you.

    The differences between the DLL 1.3 and 1.4 is that 1.3 is for Level-D 767 FS9 and 1.4 came out with Level-D 767 for FSX (but backwards compatible with FS9). 1.4 is packed with lekseecon.

    It should not make any difference, I think, but you could try to install the lekseecon software in the default folder, which at a 64 bit OS, will be C:\Program Files (x86)\lekseecon. This is a better place, because it is a 32 bit application after all. Don't forget to copy your lekseecon9.ini into the new folder.
    See what happens.

    Another thing I can offer you is the beta of lekseecon 6.1, just give it a try to see it makes any difference. At least the error message 11 is better

    If not I'll make a lekseecon version for you that skips the SDK version check, and let's see what happens then ..

    Cheers,
    Nico

  8. #8
    Our new friend needs to reach 10 posts to get to the next flight level
    Join Date
    Oct 2009
    Location
    Athens, Greece
    Posts
    7
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Error #11 trying to run latest version.

    Quote Originally Posted by kiek View Post
    Hi George,
    It's getting very strange .. all seems ok. But it still does not work for you.
    You can say THAT again!!!!

    Quote Originally Posted by kiek View Post
    Another thing I can offer you is the beta of lekseecon 6.1, just give it a try to see it makes any difference. At least the error message 11 is better
    Downloaded the 6.1Beta. Thanks... Now...

    X-Files continues...

    - When I install Lekseecon on the default location (program files blabla) it does not even start. Nor it exists in task manager. No error, no nothing...

    - When I install it in the folder I used before outside program files it starts ok, connects to SIOC... and I get the new error description about having wrong LevelD version...
    (BTW, there is a typo in the error and say "then the FS" istof "than the FS"...)

    I'm about to give up!
    George

  9. #9
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,198
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Error #11 trying to run latest version.

    Quote Originally Posted by gdorkofikis View Post
    - When I install Lekseecon on the default location (program files blabla) it does not even start. Nor it exists in task manager. No error, no nothing...
    If lekseecon starts it is normal that you see nothing (since version 6.0 it will not show up in the taskbar). Just have a look in the lekseecon9_log.txt file to see what happened. Did you copy lekseecon9.ini into that folder? Just try again, there is no reason at all why it should not work.

    Quote Originally Posted by gdorkofikis View Post
    (BTW, there is a typo in the error and say "then the FS" istof "than the FS"...)
    I told you it is a just beta

    Quote Originally Posted by gdorkofikis View Post
    I'm about to give up!
    Come on George, not so soon. There are more then 100 happy lekseecon users, we will find the error in your config.

    Nico

  10. #10
    2000+ Poster - Never Leaves the Sim kiek's Avatar
    Join Date
    Jan 2007
    Location
    Netherlands
    Posts
    2,198
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: Error #11 trying to run latest version.

    Hi George,

    Please download a new beta 6.1 in which I try to reconnect to the SDK three times (when versions are incompaible) and then lekseecon will continue...(instead of producing eror 11). In the Log there will be a message if this is the case. I'm curious for the results.

    Here is the link to the new beta lekseecon 6.1

    regards,
    Nico

Page 1 of 2 12 LastLast

Similar Threads

  1. Video Card Issues with the Latest Version?
    By rt72 in forum Instructor Station
    Replies: 0
    Last Post: 04-22-2010, 11:55 PM
  2. Re: pmSounds latest version
    By Karl Bates in forum PM General Q & A
    Replies: 0
    Last Post: 02-08-2006, 10:07 AM
  3. pmSounds latest version
    By David Rabiner in forum PM General Q & A
    Replies: 8
    Last Post: 01-28-2006, 10:03 PM