Results 1 to 4 of 4
  1. #1
    25+ Posting Member brian95's Avatar
    Join Date
    Apr 2010
    Location
    Melbourne, Australia
    Posts
    34
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    potentiometers help? bu0836

    Hi guys,
    I recently got my BU0836 card from Leo Bodnar but I am having a little problem with the potentiometers.
    All the other buttons work fine, however. As in I can connect a toggle to the card and it would work using FSUIPC.

    The problem is with the potentiometers. I connected them as the diagram on Leo's website shows. However, I'm not to certain with the potentiometer I have. It's a multi-turn wire wound potentiometer I believe. I assumed the middle contact was the wiper contact that connects to the INPUTS on the card, the +5V contact was to the pin on the other side, and the GRD pin was the one beside the middle one (but close proximity to it)
    At first using this arrangement, the potentiometer registered but did not respond, and as I was calibrating it using the game controllers from windows, there were only two values (0 and 1), instead of a smooth axis. It kept jumping from extreme left to right regardless of wiper position.
    That was what happened the first few times. Now, as I connect the wires to the card and plug it into the computer, it fails (USB Port # is not working. Please remove the device) and every other USB port stops working (mouse also stops). The only way to get them back is to restart the computer.

    Can anyone please help me here? I am not sure if I have it properly wired or if I have the right potentiometers (they are labeled WXD3-13)
    Thanks,
    Brian

  2. #2
    300+ Forum Addict



    Join Date
    Feb 2007
    Location
    California, USA
    Posts
    406
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: potentiometers help? bu0836

    Brian,

    It's possible the pot is wired incorrectly. The only spec sheet I could find for the WXD3-13 has limited usefulness, but wire wound pots by other manufacturers have the wiper connected to the end terminal opposite the shaft. For example here's a link to a spec sheet of a Bourns pot http://www.jameco.com/Jameco/Products/ProdDS/183548.pdf

    When connected incorrectly, the pot can short out the +5 power on the USB port. That might explain the symptoms you're seeing.

  3. Thanks brian95 thanked for this post
  4. #3
    25+ Posting Member brian95's Avatar
    Join Date
    Apr 2010
    Location
    Melbourne, Australia
    Posts
    34
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: potentiometers help? bu0836

    Hi Mike,

    Thanks for your reply.
    Indeed, the pot was wired incorrectly. Thank you so much for pointing it out.
    I have re-soldered it correctly and it works now.
    Again, thank you for your help.

    Brian

  5. #4
    75+ Posting Member Leo Bodnar's Avatar
    Join Date
    Apr 2008
    Location
    UK
    Posts
    97
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: potentiometers help? bu0836

    Quote Originally Posted by brian95 View Post
    Hi Mike,
    Thanks for your reply.
    Indeed, the pot was wired incorrectly. Thank you so much for pointing it out.
    I have re-soldered it correctly and it works now.
    Again, thank you for your help.
    Brian
    Hi Brian,
    It's lucky that you did not burn it. Multiturn pots are confusing because indeed their wiper is not in the middle. This is due to their construction.However most pots have the wiring diagram on the body.

    This link has wiring notes inside: http://www.leobodnar.com/products/BU...-mw22b-doc.png
    Cheers
    Leo

Similar Threads

  1. Basic help with BU0836 card
    By madladuk in forum I/O Interfacing and Hardware
    Replies: 3
    Last Post: 03-23-2011, 03:08 PM
  2. connector cables for BU0836
    By brian95 in forum General Builder Questions All Aircraft Types
    Replies: 4
    Last Post: 08-30-2010, 08:34 PM
  3. BU0836 Basic Question
    By GARich in forum General Builder Questions All Aircraft Types
    Replies: 3
    Last Post: 03-24-2009, 04:59 PM
  4. BU0836 with Bu0836X
    By KenK in forum I/O Interfacing Hardware and Software
    Replies: 5
    Last Post: 03-17-2009, 02:16 PM
  5. BU0836 + Diodes
    By flatdog in forum I/O Interfacing Hardware and Software
    Replies: 6
    Last Post: 07-14-2008, 03:37 PM

Tags for this Thread