Results 1 to 5 of 5
  1. #1
    Our new friend needs to reach 10 posts to get to the next flight level
    Join Date
    Jul 2007
    Location
    Wilmington, DE
    Posts
    9
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Question FSUIPC Mouse Macro problem w/ BU0836X

    I am using FS9, PDMG 737, FSUIPC 3.94 all running on the same PC. I am building my first panel of many hopefully as I plan to build a complete 737 setup eventually. I wanted to build a simple panel first to determine if I want to build more or purchase others already to plug n play.

    I am in the process of setting up my EFIS interfaced with a BU0826X joystick controller. I am using 4 rotary encoders for the MINS , BARO ND Mode and ND Range switches. In setting up the encoders for the PDMG I am using FSUIPC Mouse Macro's to trap the mouse click for each function and assign them to the encoders.

    My problem lies with two encoders. I have the mouse macro's configured and they oprerate the fucntion assigned but also opreate an additional function unrelated to the EFIS and to which they are not assigned ( as far as I can determine). The ND mode encoder switches modes correctly but at the same time opens up the Kneeboard and cycles through the different pages as each mode is accessed. The ND Range encoder switches ranges correctly but also lowers or raises the flaps one notch each time the range is changed.

    I have gone through everything I can think of and am at a loss as to what is causing this this to occur. I have deleted and recreated the macro's numerous times with no success. Each time after re-creating the Mouse Macro's the same additional function ( kneeboard and flap changes) occur on the same switch.

    Hopefuilly someone may have run into this before and have some advice as to what else to look for or as to what can be the cause and where to look to resolve my dilemma.

    On a last note .. is it possible that I am getting bounce from the decoders? From what I have read this shouldn't be the case with the BU0836X and the CTS288 encoders but I'll leave it to the experts.

    Thanks in advance

    Hank

  2. #2
    75+ Posting Member Jylhami's Avatar
    Join Date
    Feb 2007
    Location
    Finland
    Posts
    82
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FSUIPC Mouse Macro problem w/ BU0836X

    Make sure you don't have anything set on the FS's joystick assignments for the buttons, i remember having same kind of problem setting my 6-axis throttle when i had some previous axes configured in FS.

    And have you set the encoders properly with the bu-encoders software ?

  3. Thanks hladamjr thanked for this post
  4. #3
    500+ This must be a daytime job ian@737ng.co.uk's Avatar
    Join Date
    Jan 2006
    Location
    Oswestry, Shropshire
    Posts
    677
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Re: FSUIPC Mouse Macro problem w/ BU0836X

    hi hank......
    i was having some problems posting a reply. so i've e-mailed you.
    regards ... ian
    Mr. Ian. P. Sissons is hereby recognised as an Honorary Flight Sim Captain following his passing in February 2016. This is in recognition for his commitment to Flight Simulation.

    www.mycockpit.org Featured Builder August 2008 www.737ng.co.uk
    FS9/PROSIM737/CPFLIGHT/Lots of BU0836X's and a Beer Fridge

  5. Thanks hladamjr thanked for this post
  6. #4
    Our new friend needs to reach 10 posts to get to the next flight level
    Join Date
    Jul 2007
    Location
    Wilmington, DE
    Posts
    9
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Thumbs up Re: FSUIPC Mouse Macro problem w/ BU0836X

    Ian

    I got your email and your suggestions for checking the assignments for the BU0836X in FS was right on. I deleted several joystick assignents that FS erroneously added or created on it's own, closed and re-started FS and it reoslved the problem.

    Thanks again for another quick solution

    Hank

  7. #5
    Our new friend needs to reach 10 posts to get to the next flight level
    Join Date
    Jul 2007
    Location
    Wilmington, DE
    Posts
    9
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Thumbs up Re: FSUIPC Mouse Macro problem w/ BU0836X

    Quote Originally Posted by Jylhami View Post
    Make sure you don't have anything set on the FS's joystick assignments for the buttons, i remember having same kind of problem setting my 6-axis throttle when i had some previous axes configured in FS.

    And have you set the encoders properly with the bu-encoders software ?

    That was what the problem was exactly, there were several joystick assignments that mysteriously appeared Thanks to both you and Ian ( who responded directly to me ) You both hit the nail on the head )

Similar Threads

  1. PMDG MD11 MOUSE MACRO
    By cmdurney in forum I/O Interfacing Hardware and Software
    Replies: 0
    Last Post: 05-05-2010, 05:03 PM
  2. Macro mapping in FSUIPC....I need help??
    By Spoceto1003 in forum General Builder Questions All Aircraft Types
    Replies: 0
    Last Post: 12-05-2009, 01:21 PM
  3. LED and Mouse Macro
    By Holclo in forum Phidgets & Cockpit Simulator Builder
    Replies: 0
    Last Post: 12-09-2008, 04:58 AM
  4. FSUIPC 3.81 Mouse Macro Controls for Level-D 767
    By kiek in forum I/O Interfacing Hardware and Software
    Replies: 7
    Last Post: 07-23-2008, 12:33 PM
  5. FSUIPC/MACRO/Keysend with sioc
    By Georg Schneider in forum OpenCockpits General Discussion
    Replies: 12
    Last Post: 05-05-2008, 01:18 PM