Results 1 to 8 of 8
  1. #1
    25+ Posting Member
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    38
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Unhappy Major FSUIPC problem

    Hi people!, I have got a major fsuipc problem here.

    I dismantled my sim and mounted the shell from FDS, looks great......so far so good.

    Started up my sim with same hw and sw ( I think ) as before with full Pm suite.

    Then squawk box comes up with a pop up saying "Squawk Box module was unable to start because FSUIPC could not be initialized. Ensure FSUIPC is properly installed and restart F to try again"

    Checking with pmfilechecker reports fsuipc version 0

    I have searched the web and I have seen some replies from Pete on this issue, I have checked that antivirus a internal FW isn't blocking, restarted sim numerous times, removed key file, renamed key file with the result of an unregd
    version, then squawk box can be started but my pm will not work off-course because of a unregd version.

    registered fsuipc and widefs again, restarted sim and same problem as before.

    tried to delete squawk box and install version 3, that didn't help, tried a different old version of fsuipc ...did not help.
    Then yesterday I came to the mountain as the mountain did not come to me I installed fs on a different machine and installed the same registered fsuipc on that machine, installed widefs and connected this new machine to my pm suite machines...


    It worked....so then I tried to copy my modules folder from this new test fs machine into my old main fs machine, started fs still same problem.


    what I have learned so far...

    1. Old main fs do not work no matter what I try.

    2. New temp. fs machine works with fsuipc and widefs, same as i have in my old machine.

    3. moving modules folder over from working pc to other not working machine, does not work.


    So i went into the think box again and tried to remember what I did before I dismantled my sim.

    then I remembered I did upgrade squawk box from 3 to 4.
    but since I'm now back to version 3 of squawk box I should have been fine, I'm starting to suspect that squawk box version 4 changed some dll`s, and that reverting to version 3 again did not do any good .dll vise!

    Any help is greatly appreciated

  2. #2
    500+ This must be a daytime job
    Join Date
    Jan 2007
    Posts
    564
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Quote Originally Posted by kenlie_no View Post
    Checking with pmfilechecker reports fsuipc version 0

    I have searched the web and I have seen some replies from Pete on this issue, I have checked that antivirus a internal FW isn't blocking, restarted sim numerous times, removed key file, renamed key file with the result of an unregd version, then squawk box can be started but my pm will not work off-course because of a unregd version.

    registered fsuipc and widefs again, restarted sim and same problem as before.
    There are only two possible causes of that symptom -- either the date set in your PC is EARLIER than your purchase date of one of your FSUIPC or WideFS keys, making it look illegal, or one or both of them ARE, in fact, illegal. So ... check your system date.

    If you'd try using the proper support place for FSUIPC, the Forum as mentioned in all the docs, then you'd find this mentioned in all replies to folks with similar symptoms. Please do use the Support I provide -- I do not visit here so often.

    Regards

    Pete

  3. Thanks kenlie_no thanked for this post
  4. #3
    500+ This must be a daytime job
    Join Date
    Feb 2006
    Location
    N/A
    Posts
    511
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Do a system restore...

    Hey, try doing a system restore to a date on or before you disconnected your setup and added the FDS shell. You can select any system check point prior to last date that everything was working and likely, your FSUIPC, WideFS, etc should work...

    Oh, you did not say if this is WinXP or Vista, but in either case you can do a restore.

    Good Luck.

  5. Thanks kenlie_no thanked for this post
  6. #4
    25+ Posting Member
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    38
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Thumbs up

    Tx to both of you i`l try that, fsuipc is very legal, I must have bought it like 3 times since I first started to use it

  7. #5
    1000+ Poster - Fantastic Contributor Bob Reed's Avatar
    Join Date
    Oct 2005
    Location
    Holley, New York U.S.A.
    Posts
    1,880
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Here is a question, is the network working? It sounds like it could be a network issue.
    Bob Reed

  8. #6
    25+ Posting Member
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    38
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    It works again after a system restore, really dont know what this was but tx for your help all.

  9. #7
    500+ This must be a daytime job
    Join Date
    Feb 2006
    Location
    N/A
    Posts
    511
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    System Restore is Great

    I'm glad all is working for you now. I think System Restore is the best part about Windows OS. I suggest that more folks use it and create restore points prior to installing software, program updates or windows updates. In most cases, system restore will undo whatever was done that caused whatever problem.

  10. #8
    75+ Posting Member
    Join Date
    Apr 2008
    Location
    Frankford, Ontario
    Posts
    76
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Quote Originally Posted by jkcombs View Post
    I'm glad all is working for you now. I think System Restore is the best part about Windows OS. I suggest that more folks use it and create restore points prior to installing software, program updates or windows updates. In most cases, system restore will undo whatever was done that caused whatever problem.
    Hmmm… the best part about an OS is that you can undo stuff which screws up the OS, including upgrades, legal installs etc… man, am I glad I use a Mac.

    Of course MacOS doesn't support MSFS, so I have to use Windows for that.

Similar Threads

  1. Fsuipc offset problem??
    By spitfire9 in forum Phidgets Interface & Alan Dyers' FS2Phidget
    Replies: 1
    Last Post: 02-23-2011, 02:44 PM
  2. Major refit
    By richard hutchinson in forum My Cockpit Update
    Replies: 3
    Last Post: 10-25-2010, 04:22 AM
  3. FSUIPC Mouse Macro problem w/ BU0836X
    By hladamjr in forum I/O Interfacing and Hardware
    Replies: 4
    Last Post: 12-31-2009, 10:33 AM
  4. Problem setting up FSUIPC and GC Demo
    By TobiD in forum PM General Q & A
    Replies: 7
    Last Post: 02-16-2008, 11:04 AM
  5. I have a reverser problem, possibly FSUIPC related...
    By Michael Carter in forum I/O Interfacing Hardware and Software
    Replies: 8
    Last Post: 11-21-2007, 02:44 PM