Results 1 to 4 of 4

Thread: Offset question

  1. #1
    25+ Posting Member
    Join Date
    Dec 2007
    Location
    New Zealand
    Posts
    52
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Offset question

    Hi all

    I use gfdisplay to drive the indicator leds on a gf t8 module. I want to use one as a stall warning. I am currently using offset x36c which seems to give me a stall warning, but the led seems to stick on - once the stall recovery has occurred the lamp remains. If I then stall again it will go out.

    Am I using the right offset?

    Thanks

    James
    CH Yoke
    CH Pedals
    2 Saitek TQ`s
    Opencockpits multiradio
    GF LGT + T8
    BU0386x and custom autopilot control panel
    Basic pedestal and mip for generic GA sim in progress..

  2. #2
    Heli Builder fweinrebe's Avatar
    Join Date
    May 2008
    Location
    Namibia
    Posts
    325
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Hi

    the only offset I can find for the stall warning is 0x036C, so you are correct.

    I suspect the problem is in your code. Can you post the code so that we can have a look at it?
    Fritz -> Helicopter Cockpit Builder
    (FSX | TH2Go | Arduino | C# Avionics | CNC)

  3. #3
    75+ Posting Member TasKiNG's Avatar
    Join Date
    Jul 2008
    Location
    Derby, England
    Posts
    143
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    I am using that offset for stall on the FSX Learjet45 and it works correctly.
    I suggest that you use FSInterrogate ( included in the FSUIPC SDK ) to monitor this offset then you will know whether the problem is with the Sim Model or your interface code.

    Cheers

  4. #4
    25+ Posting Member
    Join Date
    Dec 2007
    Location
    New Zealand
    Posts
    52
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Hi and thanks for the replies.

    Further analysis of this issue shows that the light consistently comes on with the first stall warning. However, I`m using the fast flash syntax in gfdisplay to flash the light for 3 seconds followed by a steady illumination. It seems to depend on the state of the light when the stall condition clears. If it is flashing and off it remains off but if it is on (either flashing or steady) it will stay on.

    I`m not near my fs pc at the moment but will post my gfdisplay.ini tomorrow. I will try removing the flash syntax and see if that helps.

    Thanks again

    James
    CH Yoke
    CH Pedals
    2 Saitek TQ`s
    Opencockpits multiradio
    GF LGT + T8
    BU0386x and custom autopilot control panel
    Basic pedestal and mip for generic GA sim in progress..

Similar Threads

  1. ILS offset
    By edo17982 in forum lekseecon Q&A and Discussions
    Replies: 2
    Last Post: 09-12-2010, 06:58 PM
  2. Offset question?
    By Daveanne in forum General Microsoft Flight Simulator 2004 (FS9)
    Replies: 3
    Last Post: 01-02-2010, 01:54 PM
  3. Offset Question
    By cpeckinpaugh in forum FS2Phidget Users
    Replies: 5
    Last Post: 04-18-2005, 07:37 PM
  4. Offset again
    By lucas1971 in forum FS2Phidget Users
    Replies: 3
    Last Post: 12-09-2004, 01:49 AM
  5. Question for Alan re: offset trigger ranges
    By rangepig in forum FS2Phidget Users
    Replies: 3
    Last Post: 11-22-2004, 10:46 AM