Results 1 to 5 of 5
  1. #1
    75+ Posting Member rt72's Avatar
    Join Date
    Oct 2007
    Location
    Saint Paul, MN
    Posts
    93
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    OpenCockpit SIOC Newbie

    Hi all,


    I've been trying to work this out, however I've hit a frustration point and wondering if anyone can take a quick look and see if anything is wrong here.

    I've got a USBOutput card:

    Registers as device 45
    Connection is good using output test software

    I'm trying to simply get a bulb to illuminate when changing the state of the pitot heat from off to on.


    The file compiles OK and my SIOC.INI file has the card listed appropriately and loads this .ssi file on SIOC start.


    Any help would be greatly appreciated!

    ------------------

    // Pitot Heat Test Code //

    Var 7, Link IOCARD_OUT, Output 0, device 45

    Var 8, Link FSUIPC_IN, Offset $029C, Length 1
    {
    IF V8=1
    {
    V7=1
    }
    ELSE
    {
    V7=0
    }
    }
    -------------------------

  2. #2
    500+ This must be a daytime job 737NUT's Avatar
    Join Date
    Feb 2006
    Location
    Indianapolis, IN
    Posts
    778
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    which version are you using?

  3. #3
    75+ Posting Member rt72's Avatar
    Join Date
    Oct 2007
    Location
    Saint Paul, MN
    Posts
    93
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    SIOC 3.5
    FSUIPC 3.75 Registered
    FS2004

  4. #4
    500+ This must be a daytime job 737NUT's Avatar
    Join Date
    Feb 2006
    Location
    Indianapolis, IN
    Posts
    778
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    OK, download the sioc.ini setup program and run it. You will make your card either 0,1,or 2. That is your device number, not 45. Get that fixed and all will work. I just went thru the same thing.

  5. #5
    75+ Posting Member rt72's Avatar
    Join Date
    Oct 2007
    Location
    Saint Paul, MN
    Posts
    93
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Thanks, I'll give it a whirl!

Similar Threads

  1. Opencockpit and usb output
    By jespergb in forum General Builder Questions All Aircraft Types
    Replies: 9
    Last Post: 02-21-2011, 12:52 AM
  2. Newbie to forum, sort of newbie to flight sim!
    By jtthorpe33 in forum Welcome to MyCockpit New here? Introduce Yourself!
    Replies: 4
    Last Post: 08-27-2010, 02:44 PM
  3. OpenCockpit MCP Configuration
    By aviatorden in forum Computer Hardware Setup
    Replies: 8
    Last Post: 01-08-2010, 12:34 PM
  4. Bug in Opencockpit IOCARD
    By oliver_mpt in forum I/O Interfacing Hardware and Software
    Replies: 6
    Last Post: 12-19-2008, 12:46 PM
  5. opencockpit tutorial?
    By imported_767300 in forum OpenCockpits General Discussion
    Replies: 4
    Last Post: 03-20-2008, 08:22 PM