Results 1 to 3 of 3

Thread: Q for Alan

  1. #1
    25+ Posting Member
    Join Date
    Aug 2007
    Location
    Aussieland
    Posts
    52
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Q for Alan

    I have a interesting problem with the phidget encoders and fs2pidgets. The problem happens when I am using the pm737MCP.ini offsets. In fs2phidgets there is the phi value column and the FS value column. When your turn the encoder slowly the phi value is +1 or -1 depending on direction. If you go a bit quicker the phi value goes from 1 to 2 then 3 and so on, turn the other way and it goes -1 -2 -3 etc. The problem I have is when the phi value goes from + 1 to +2 the FS value reverses. So in the case of the alt setting +1 counts it down and -1 counts up, but when the phi value hits +2 because the encoder is being turned quicker the alt starts counting up instead of down. Now the interesting thing is it doesnt happen when you go the other way, -1 -2 -3 in this case the FS value doesnt change.
    I hope I have explained it here as its hard to describe.
    Anyone else noticed this?

    thanks
    Jeff

  2. #2
    1000+ Poster - Fantastic Contributor Bob Reed's Avatar
    Join Date
    Oct 2005
    Location
    Holley, New York U.S.A.
    Posts
    1,880
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Hmmm Alan will have to step in here but are you using the Phidgets encoders? Almost sounds like the encoder is not counting properly....
    Bob Reed

  3. #3
    25+ Posting Member
    Join Date
    Aug 2007
    Location
    Aussieland
    Posts
    52
    Contribute If you enjoy reading the
    content here, click the below
    image to support MyCockpit site.
    Click Here To Contribute To Our Site

    Quote Originally Posted by Bob Reed View Post
    Hmmm Alan will have to step in here but are you using the Phidgets encoders? Almost sounds like the encoder is not counting properly....
    Yes they are the standard phidget encoders. I thought that 1 might have been faulty, but they all do it using the PM737MCP.INI. When using the normal FS offsets it dosent seem to be as tempermental.

    Jeff

Similar Threads

  1. LED-Brightness in LED64, to Alan
    By imported_EW321 in forum FS2Phidget Users
    Replies: 11
    Last Post: 06-27-2007, 06:20 AM
  2. Where's Alan Dyer and Bete 3.0
    By cpeckinpaugh in forum FS2Phidget Users
    Replies: 2
    Last Post: 04-23-2005, 10:10 AM
  3. Question for Alan
    By project717 in forum Phidgets & Cockpit Simulator Builder
    Replies: 1
    Last Post: 04-04-2005, 12:45 PM
  4. Is the new version almost ready Alan?
    By lineman55 in forum FS2Phidget Users
    Replies: 3
    Last Post: 03-28-2005, 07:40 AM
  5. Question for Alan D. APU offsets
    By imported_737nut in forum FS2Phidget Users
    Replies: 0
    Last Post: 11-01-2004, 11:50 PM