PDA

View Full Version : PSXseeconTraffic also supports FSX!



kiek
03-10-2017, 10:27 AM
PSXseeconTraffic (http://www.lekseecon.nl/PSXseeconTraffic.html)beta version 5.15, now supports as well Prepar3D v2.5 or later or Microsoft Flight Simulator X SP2.

Nico