View Full Version : Overhead with InterFaceIt

11-11-2016, 01:51 AM
Jon Luc, I have found a major problem with the InterfaceIt overhead.

I am unable to start the APU on my InterFaceIt overhead, but can start ok with the graphic overhead and the IIT one turned off.

Have checked the switches out all ok.

Here is a log of the startup:

*Date of file:12/11/2016
*3:22:07 PM*:HardwareConnect Launched
*3:22:15 PM* CPFlight:Port opened
*3:22:15 PM* CPFlight:Connected
*3:22:15 PM*:C:\A320FMGS\Hardware Modules\CPFlightmodule.dll loaded
*3:22:15 PM*:C:\A320FMGS\Hardware Modules\FSUIPCmodule.dll loaded
*3:22:15 PM*:C:\A320FMGS\Hardware Modules\interfaceITAPI.dll not valid
*3:22:15 PM* JeeHell_IIT:Get Log Proc
*3:22:15 PM* JeeHell_IIT:End of Start procedure
*3:22:15 PM* JeeHell_IIT:Get SW Proc
*3:22:15 PM* JeeHell_IIT:Get Analog Proc
*3:22:15 PM*:C:\A320FMGS\Hardware Modules\JeeHell_IIT.dll loaded
*3:22:15 PM*:C:\A320FMGS\Hardware Modules\SIOCmodule.dll loaded
*3:22:15 PM* JeeHell_IIT:7seg except
*3:22:15 PM* JeeHell_IIT:7seg except
*3:22:15 PM* CPFlight:0
*3:23:47 PM*:HardwareConnect closed

Looks like the interfaceITAPI.dll maybe the trouble.

Will have another look tomorrow and if you have any suggestions where I maybe able to fix it, please let me know.

Many thanks.............Brian W.

11-11-2016, 03:56 PM
Hi Brian,

The interfaceit.dll being not valid is normal.
How did you assign the switch? can you put a screen shot?
Did you try other switches?


11-11-2016, 07:25 PM
Gooday JL, Have tested all the switches and as far as I can tell all working ok on the overhead, but may need to go and do the whole overhead, as new, to make sure.

Here is a pic of the Master switch assignment

Cheers...............Brian W.

11-11-2016, 08:02 PM
Perhaps I can ask if there is anyone else using Interfaceit with their overhead switches on V46 with P3D V3 that is finding that it works ok.

Then I know that I will need to re-assign the switches on my card.

Many Thanks................Brian W

11-12-2016, 02:33 AM
Looks good...
Can you describe the exact behavior? You say you can't start the Apu, but what part is not working exactly?
Also try to turn the logging on for the inputs in hardware connect then press the master button to see what happens.

11-12-2016, 01:35 PM
I use the FDS Sys Interfaceboard and P3D v. 3.4 too. I have no problem to start the APU.
You have fuel on board?
Save your settings again in the IITcreator and create a new IIT.dnt with the new FMGS Version.
Sometimes this also helps.

11-12-2016, 04:35 PM
Thanks JL. The main problem is that the APU Master switch is not turning on, even though as you can see from the picture it is being picked up by IIT board.

So, a big thanks to Fritz which has probably given me the answer. That is, that there is something regarding the swwitches on that InterfaceIt board that is not correct, so I will need to completely re-assign all the switches.

That is such a big help when somebody has it working with a similar setup to mine, then I can hopefully fix the problem.

A big thank you both........................Brian W.

11-12-2016, 09:47 PM
Just a quick side note before I do any drastic re-programming of the switches.
Is it normal to have the switches to do the following:

Card Type 4105
Switch Action 97
Card Type 4105
Switch Acton -9999

...............Brian W

11-13-2016, 02:18 AM
Another fault on new install with scan on hardware :

Jeehell_IIT cannot read MVDU1 pot

Any clues on this one ?

.............Brian W.

11-13-2016, 04:10 AM
SWs with action=-9999 try to reassign them...
MCDU Pot: not sure what you mean here? They were never assigned through IIT creator, but are automatically detected with the MCDU module?

11-13-2016, 01:43 PM
Hello Brian,

you do not need to make a completely re-assign for all switches.
Only delete the assigment for the switch whitch is not working and press save.
Then assign again the switch.
I also use two FDS MCDUs but the Dimmer Pot on the MCDU is not supported in FMGS as I can remember.

Regards Fritz

11-14-2016, 01:53 AM
Ok just to report as to my findings so far.

I was unable to even get the 2 computers to connect to each other with V46 in the end. The further I went the worse it seemed to get. No way could I get the overhead APU Master switch to come on.

So I then went back to V 45.4 and got most of the switches on the overhead working, but no Master APU again. It kept coming up with the -9999 thing

So a moment ago I threw out the IIT.dnt and just programmed the Bat switches and the APU switches and presto, it worked.

So I will have to re-do the lot as it seems not to be able to fix by deleting the button and saving, then redoing the button.
Then I guess I will retry V46............................

Many thanks for the suggestions.....Brian W.

11-15-2016, 01:39 AM
Well the mystery deepens. I completely re-did the overhead switches and leds.
Fortunately I did the switches first and saved them and then added the leds in a second .dnt
Now I started a completely new re-install of 45.4 and inserted the new dnt file. Same story . It all looked normal until I hit the Master APU..................no go.

So I the re-installed the .dnt without the leds installed and the APU Master worked.

So something it appears is corrupted in the led side of the board which happened after I tried installing v46, but there maybe no connection.
Here is one file with the switches and leds, just logging the leds.

The led log goes crazy, so there is a big problem there, as I only put a fraction of the files here.

Anybody that has had these problems with InterFaceIt boards, please give some info if you can....................Brian W.

11-15-2016, 04:02 AM
Your log is normal, the entries are for the CPFlight FCU and perfectly normal.
Can you send me the two .dnt files (with and without leds) so I can have a look at them?
I don't think there is any problem with the interfacit boards in general? This is either a small glitch or a user misuse, but I guess we'll find out after I get the dnt files...

11-15-2016, 08:46 PM
USER MISUSE............................It was something that happened some time back that I did not recall, which turned to be a reversed Fire switch.

I pasted in a dnt file that was before the correction from ages back, unbeknown to me. Not sure if I had some files deleted by Windows Defender, which I thought was turned off, but was not completely off, as I do not use the computer on the internet.

So now to install the latest version after I do some serious backups.

Thanks all................Brian W.

11-23-2016, 07:55 AM
I am having problems with a few switches on my overhead but my APU start works fine.

11-24-2016, 01:31 PM
Gooday Barry,

I noticed you were having a few headaches with the overhead. I was too, at one stage until I put in another FDS switch board, which solved the problem.

Finally put V 46 in and all test very well, but have only done some short test flights,

Cheers..................Brian W.

11-24-2016, 02:37 PM
Not too many problems, all soluble but like you might need more hardware. A shame as all worked with AST. Nav switches one problem, also Transponder. Might need to convert some overhead switche from on/off to toggle.
More work, I just want to play!

11-24-2016, 03:20 PM
BArry, I may try to chagne a bit how the FDS driver works in the next days (some spare time...). This may imply a complete reassigning of all the switches though... but if you are willing to test that...

11-24-2016, 07:16 PM
More than happy to test as it will not only help me but I am sure others will run into the same issues. Thank you for the support you give us.

11-25-2016, 09:22 AM
Hi Barry,
Ok I think it was much easier than I thought...
try that:
You will need to unzip the files in your c:\A320FMGS\Hardware modules folder, replacing the previous ones.
It will create an IIT.dnt2 file, so your old one should not get erased. BUT MAKE A BACKUP anyway.
You cannot use both DLL versions at the same time (the DLL will take ownership of all the IIT boards...).
This is highly untested, so far from a production version, until someone makes comprehensive tests with it (several boards, several switces/LEDs per boards, mixed with modules, etc...).
But I conducted one small test with 3 buttons, including the IRS selector, and it worked...
Please keep us posted...


11-25-2016, 11:53 AM
Will try over the weekend.

11-26-2016, 01:24 PM
OK we have loaded the switches, first results encouraging but with some different results.
First point is that I can turn the ADIRS On and Off with just the one wire to the nav position. Rapid alignment! Magic !!!
I have a mix of on/off and toggles. Looking at the on/off only at this point I can get two results from the same settings, for example:
With the APU running I can turn bleed air on with a press and when I press again it turns off, more magic.
If however I play with the ADR1 switch, I can turn it on. Then when I turn the switch off it does not turn the system off but if I turn the switch on again it turns the system off. So it's like a toggle but I have to press twice to turn off and then twice to turn on again.

The way the bleed works as I would expect leads me to think I am using the setting procedure correct using switch down and switch up.

Perhaps the system is making assumptions as to which switches I have set up as toggles and which as on/off. I worked to a plan FDS gave me some years ago but perhaps it is not correct (so perhaps the system expects my ADR1 to be a toggle and not an on/off, it would work correctly then).

I have not checked all of the switches yet, as you know a full reprogramming is quite a long job but worth it when we get it all working.

Any comments anywhere?


11-26-2016, 03:25 PM
Hi Barry

The ADR switches are indeed toggling ones... So the soft does not allow the on off positions. What you can do to bypass that: select the Down action for both positions. This way, every time you press the switch (locking or releasing it) it will send the down event.

There are a few others which are toggles. Off my head:
- Apu master
- yellow elec pump
And some others probably...

Jean Luc

11-26-2016, 05:04 PM
I found back this list I had made. Not necessarily exhaustive:
-yellow elec pump
-Fire Agents


11-26-2016, 06:21 PM
Thanks, going well so far but it's a long job reassigning all the switches and led's.
No faults found yet.

12-01-2016, 06:01 PM
I have just about all of the overhead and MIP working properly, have had to experiment with settings on quite a few.
The only function so far which I have not been able to get working is the gear switch. Mechanically it is a switch which makes with the gear up and breaks with gear down. I can select gear up and it works. Selecting gear down does not work but pressing G on the keyboard puts it down with correct lights.
Any suggestions welcome.

12-01-2016, 06:41 PM
This is strange.
Can you test with for instance a joystick button?
I will try to test that tomorrow evening on my side, but this sounds weird.
Which actions did you select for the gear down action?

12-02-2016, 06:18 PM
OK JL, it is fixed. I put together a matrix of all the options switch up/switch down and gearup/geardown and flew them on circuits until I hit on the one that worked. Gear is harder than system switches as it is necessary to get off the ground to test it.
i think JL that you have created a lot of flexibility with the program now which enables us to select the combinations for our hardware. Toggles, switches, rotaries etc, just needs a lot of patience to get each switch right! Takes hours of work!

12-06-2016, 05:18 PM
Hi, just trying the new DLL, what i found is i can't set my 3 position switches for example "no smoking" to the AUTO position we can select only from On/Off 'cause previously the software made automatically the assumption if it's not On or Off then it will be AUTO, so can you jeehell insert all the 3 position for all the switches that have those? I have real switches so wired all the three position... best regards...

12-06-2016, 05:22 PM
The same assumption is used. For the middle position, use the same action but with sw up event.

12-06-2016, 05:50 PM
The same assumption is used. For the middle position, use the same action but with sw up event.

Ok thanks, now the no smoking work, but the Emer EXT LT is a little strange, first the overhead graphic switch is not in sync with the hardware one and it seems there's a problem there in the logic can you check?

12-06-2016, 05:55 PM
Further testing...when i start the software the position of other switches are recognised fine but the EMER EXT LT not...

12-10-2016, 02:26 PM
The same assumption is used. For the middle position, use the same action but with sw up event.

Hi, found something... i want a switch to work in reverse order specifically the Overhead Beacon, i want to assign 1st action on SWdown Beacon OFF and in SWup Beacon On when i save it and reopen in ittcreator they are both OFF tried many times but not work...

2) sometimes after a little the led assignment action list become all white and can't select nothing minor issue...you have to restart creator to populate again.

Update 1: also RWY turnoff don't work well

12-12-2016, 11:58 AM
The same assumption is used. For the middle position, use the same action but with sw up event.

Hi Jeehell, i think i've found where the problem lies on the 3 position switches we have to talk about the logic of them where can we talk about?

12-12-2016, 05:57 PM
here seems the good place...
I do not see what are your problems? What was possible in previous IIT version is still possible?

12-12-2016, 06:58 PM
here seems the good place...
I do not see what are your problems? What was possible in previous IIT version is still possible?

Ok, i try to explain here but it will be better to have a chat anyway, let's start with the 3 position switches problem (we just try with no smoking OFF-AUTO-ON) here is an example that you can verify first the configuration on ITT:

Switch n.1:
On switch down: OVHD NOSMOKING OFF - assigned action switch down
On switch Up: OVHD NOSMOKING OFF - assigned action switch up

Switch n.2:
On switch down: OVHD NOSMOKING ON - assigned action switch down
On switch Up: OVHD NOSMOKING ON - assigned action switch up

Now my hardware switch is set to OFF if we start the FMGS it perform the first scan of switches and because the last switch with the same function in this case number 2, it put the overhead software switch to AUTO (different than my hardware position) this is why:

IT think scan switch 1 is it down? yes so put it to OFF
then scan switch n.2 is it down? no is up so put to AUTO
here is the bug, after the initial scan you have to make a subroutine for those type of switches where the last assumption is based on a different logic here is an example:
Scan performed so now we need a subroutine to check:
switch1 down and switch2 up put it to OFF
switch2 down and switch1 up put it to ON
put it to AUTO

So it will get in sync with the first startup either i have to cycle all the switches to sync them correctly.

Hope i was clear any thoughts?

12-13-2016, 12:18 PM
I see your problem. I will try to add some more logic later on, not much time to work on FDS interface...


08-01-2017, 11:21 AM
Hi, have you corrected this?

08-01-2017, 11:29 AM
not yet..

08-04-2017, 02:35 AM
Is this something which has to be considered in sioc support also? As a workaround it can be fixed with own sioc code, I guess.