View Full Version : No connection to FS9

11-06-2012, 12:58 AM
Hi all!

I've the newest FMGS installed but unfortunately cannot connect to FS9. I had the problem already ones and i did the calibration of joystick again and it worked. As i didn't used it that time I've it deinstalled until i started more seriously with my hc project.

Now, again the same problem, everywhere red 'not connected to fs'. I'm wondering if I'm the only one who did something wrong in setting up?

I've everything on the same pc, so there's no network issue, it's still a test. The pc should have enough power for the test and as I said it worked once.

Fsuipc is the latest version as well.

Actually i've only one simple joystick with throttle. Therefore I can only calibrate the three Cpt axis and throttle in configuration for both LVR. To calibrate the tiller, I used as well the rudder axis. But I have no HW to calibrate flaps and spoilers. Is that the issue?
I also used to set up the errors and I took care that they do not overlap.

I loaded the navdata successfully. I did also marked the checkbox that FS is on this PC during the installation.

I get no fs9 connection even if I use the starter file, but neither if I do it manually in that sequence:
Start FS9
FSUIPC Connect
FMGS Server

All indications remain red and not connected to FS. I did already a reinstall. And I'm using also the aircraft delivered with the package. Anyway FSUIPC should be available before loading the aircraft as I know.

Perhaps somebody had similar issues who can advise me what was the promlem in that case. I would be glad to use the FMGS as it lookes great and JL did an excellent job!

Thanks for your help, Dani

11-08-2012, 07:05 AM
Hello Dani,

If the Server shows the other software as "not connected", then the most probable case is that you did not run FSUIPCconnect.exe. From what you say, it is not the case, so it could be FSUIPC which is not correctly installed. Do you have the Add-ons menu in FS menu bar? Did you try to reinstall FSUIPC?

Also some people have had huge problems with antivirus which blocks the software and put them into "sandboxes" or whatever they call it. These mode of operation blocks all communications with other software. I know at least Norton and Avast use that.

Cocnerning the axis calibration, if you calibrated the rudder, do not calibrate the tiller on the same axis. Though it is NOT the reason for your troubles.
Flaps and spoilers axis are not necessary, only at least one side CPT or FO and the THR LVRs.

Best regards,

11-13-2012, 03:15 PM

Thanks for your reply. I guess that FSUIPC should be fine and ready. But you're right, I've Norton installed and saw that a connection was blocked. I changed the config in Norton, unfortunately it still doesn't work. But I'll focus on that and conduct some more trials.

Thanks and best regards

11-26-2012, 04:32 AM
Did you fix it Dani17? If not, there are a couple more things to check:

FSUIPC should be registered; FMGS only runs with paid-up copy. You said you had the latest version but check its not 4.7; I think there were problems with this and Beta 22(?) so best to avoid it.

I'm unsure about this, but check widefmgs.ini file in WideFMGS folder. Mine has an 'ip=A.B.C.D' entry which I'm not sure whether I put there.

Make sure AP.FBW is started (which you seem to do anyway); I add "AP.FBW=yes" in my starter.ini file to ensure this.

FS9 should be running; make sure it is not paused. On a single PC, each time you click on an FMGS window FS9 is paused; so be careful.

- and of course, keep FMGS and FS9 on the same PC until its checked out. (I tried to emulate your situation but got my settings mixed so I had to abandon the tests before I got too muddled, sorry).

Keep at it - JeeHell's gift is worth the effort - and best of luck.

EDIT 27/11 - FSUIPC does not have to be registered for FMGS (JH Generic Gauges do though). FYI I tested FSUIPC 3440 and 3999 successfully with FMGS on same PC.