PDA

View Full Version : Anti Ice Annunciator Led Problem



Peter Nielsen
05-06-2009, 08:55 AM
Hi,
<o></o>
I have a strange problem in that the Cowl Valve Open annunciators on my overhead never light up.
<o></o>
Believing this to be a case of crossed wires or bad soldering I recently tested the leds (they both light up ok) and then re installed the Phidget 64led card to which these are connected from scratch.<o> </o>
<o></o>
Results the same as before.<o> </o>
<o></o>
These two do NOT light up using the Phidget menu and assignment check within PM systems.<o> </o>
<o></o>
These two do NOT light up using the Master Light Test switch.

They obvioulsy do NOT light up either if i use Anti Ice..
<o></o>
If I disconnect these from the Phidget Card and use a voltimetre or battery check against the actual Phidget 64 connector then the work and light ok OK..<o> </o>
<o></o>
Im confusedů any ideas?<o> </o>
<o></o>
BTW ALL other LEDS and Switches are working as they ahould..

Rgds
Peter
<o>
</o>

dnoize
05-06-2009, 12:19 PM
are you using 2 leds in series and one of the 2 is reversed in polarity ?



Stef



.

Peter Nielsen
05-06-2009, 12:39 PM
Hi Stef,

Nope I already checked that..:)

Cheers
Peter

barkay
05-07-2009, 02:32 AM
Peter,

I do not have any idea how phdigets work but I use SIOC with PMsystems and my experience is sometimes the PM systems value messages are decoded reversly. I mean when the led is on at PM systems the value is given as 0 instead of 1 so SIOC gets confused. For such situations I have added a simple code to reverse the command. Simply if PMsystems variable is 0 then SIOC variable is 1 sort of thing.

If you are able to do this in Phidgets this could be the only advise I can give...

I hope it works

Regards,

barkay

Thomas Richter
05-14-2009, 09:34 PM
Hi

If you take a look to the Offsets you will find that they are Bytes and not Bits. And more you will see that they have the state
0 = OFF
1 = DIM
2 = BRIGHT

So you need to setup your hardware in this way to get it work.