View Full Version : Flight Illusions cant find Com Port in PMSystems

02-23-2009, 05:02 PM
I am having problems with the Flight Illusions overhead gauges detecting the com port. I am using XP and when I check device manager, the USB serial port is set to Com 3. In the PMSYSTEMS text file. I have it set to com 3. I ran the scan and have the parameters set
in the Flight Illusions Text File to.

180, 1, apuegt, 0.72, 40000
181, 1, cabinclimb, 1, 1000
182, 1, cabinalt, 1, 500
182, 2, diffpress, 0.7, 500
183, 1, bleedpsi1, max 80, 500
183, 1, bleedpsi1, max 80, 500
183, 2, bleedpsi2, max 80, 500
184, 1, fueltemp, 120, 4500
185, 1, cabintemp, 0.66, 2000

PmSystems does not see the gauges. I have even tried to uninstall and re-install the driver.
I have installed GS Control version 6.0.3 and it cant
find the any com ports either, it shows 0. I have 8 Phidgets cards and Flight Illusions gagues connected to two 7 port USB Hubs. My Phigets cards are working fine.

I connected the gauges to another computer and installed GS Control version 6.0.3 and it finds all six gagues.
If I uninstall the USB to Serial Driver, GS Control sees Com Port 3. I am stumped. I have spent hours trying to figure this out.



Trevor Hale
02-24-2009, 08:56 AM
Hi Den,

I know there is an easy solution to this. I have seen it somewhere here before. try a search in the forum for Overhead gauges and see what you come up with.

02-24-2009, 10:39 AM
Thanks for the reply Trever,

I checked the forum and couldn't find anything. I think the problem is the USB serial port is using the same port as another process. In device manager, I see two host controllers with different address but same IRQ (21). Not sure how to fix it. XP wont allow you change the IRQ. It is assigned by the BIOS. IF I try to change the port other the com3, it gives me a warning that some other process is using that port.


02-24-2009, 10:54 AM
I connected the gauges to another computer and installed GS Control version 6.0.3 and it finds all six gagues.
If I uninstall the USB to Serial Driver, GS Control sees Com Port 3. I am stumped. I have spent hours trying to figure this out.



That sounds like a power isssue at the usb hub, could be wrong. One hub is not connected to the other and then only one usb cable from the computer to both hubs? Use one cable to the computer for each hub. I have also seen that some ports on computers are not good with powed usb hubs. Might try swapping cables around. And get the one hub with you gauges working first, leave everything else unplugged. Other than that have you tried;

Open the Windows Device Manager.
Right click on the COM port you want to change.
Left click on Properties.
Click on the Port Settings tab.
Click on the Advanced... button.
Use the drop down list to select the COM port number you want to use.
Click OK.
Click on OK again and close Device Manager

Trevor Hale
02-24-2009, 11:10 AM
Hmmmm. Very interesting..

There must be a way you can change the port Number in the device manager.

the thing is.. it is a USB to Serial adapter.. Remember, Port 1, and 3 use the same IRQ, and 2 and 4 use the same IRQ.


02-24-2009, 11:26 AM
Port conflicts on serial com ports are very common,

If you are not using the onboard serial port go into the bios and disable it, you will then have freed up this port for reallocation, simply go into device manager and you should be able to relallocate the device a new com port number by clicking on the device and going into the advanced settings.

I'm not on a pc at the moment that has serial or I would talk you through it step by step but it is pretty easy once you find the setting to change it.

Finally you'll need ot go in and edit the new com port number on your .ini file

Hope this helps



02-24-2009, 08:04 PM

I turned Com Port 1 off in the BIOS and removed the USB Com Driver. Re-installed and I finally got GC Control to find the gauges on com port 10. Thats the good news. The bad news is PMSystems can't find them on Com Port 10. I let it run for a about 1/2 hour. Any Sugestions.



02-25-2009, 05:04 AM
Hi Den, thats good news mate, were nearly there now.

Now that you have freed up com1 you will be able to rename your com10 to com1.
this is done by going into device manager, clicking on the ports + sign to bring you down a level then double click the com10 port, now you'll have to do a bit of hunting around but I am positive there is an option to relabel the com port, select com1 here and then click ok then do a reboot, now when you log back in check it and it should say that the device is on com1.

Edit you .ini file and away you go mate.

Dont forget that you will need to do this for each usb port that you plug your usb cable into so safe bet is to always plug it into the same usb port to avoid any hardship.

let me know how you get on mate


02-26-2009, 10:26 AM

We finally got the gauges to work. I ended up having to remove modem and sound cards that weren't being used. I think the problem was the modem card.
Thanks for you help.