PDA

View Full Version : FSX Sound Problem



airwolfe
02-11-2009, 08:28 AM
When I start my flight the sound is fine, then after I get to about my cruising altitude, I hear a distinct pop... followed by a series of pops and cracking noises that make my flying experience unbearable. I added a sound card (to replace my onboard sound device) but that did not change anything.

I am running FSX Deluxe SP1 on Vista64Ultimate.

mnovak22
02-11-2009, 08:55 AM
have you tried installing SP2? Not sure if this will solve the problem, but in general SPs are fixing known issues so you never know...
Hope this helps.

Peter Dowson
02-11-2009, 09:08 AM
When I start my flight the sound is fine, then after I get to about my cruising altitude, I hear a distinct pop... followed by a series of pops and cracking noises that make my flying experience unbearable. I added a sound card (to replace my onboard sound device) but that did not change anything.

Is the frame rate quite high when cruising, like over 50 or so?

I think both FS9 and FSX can develop very clipped sound (which does give bad pops and crackles) with some sound cards and drivers, or even mobo sound chips (which these days are similar to the separate card ones) when the frame rates are high. I assume it is trying to handle the sound faster than the chipset can take it.

The only solution I ever found when that happened was to limit the frame rate -- on FS9 to 50 or less, on FSX maybe 30, though I've not had it happen with my latest rig and FSX so I'm not sure. On my previous one I couldn't get to 30 in any case! ;-).

Regards

Pete

AchillesP
02-11-2009, 09:14 AM
Hi,

This happening with ATI cards and heavy clouds. You have enough frames but it create chocks and have problem with sound.


When I start my flight the sound is fine, then after I get to about my cruising altitude, I hear a distinct pop... followed by a series of pops and cracking noises that make my flying experience unbearable. I added a sound card (to replace my onboard sound device) but that did not change anything.

I am running FSX Deluxe SP1 on Vista64Ultimate.

airwolfe
02-12-2009, 08:35 AM
My frame rate is locked at 20... I do have most other settings at very high though. I have tried turning settings down and setting clouds to simple, still the same problem at the same time. Often it is worst when I am descending into the airfield... regardless of the amount of traffic.

Kennair
02-12-2009, 08:50 AM
Airworlfe. I would highly recommend installing SP2 as many addons specifically require it, and it also fixes a number of other problems such as multicore support. All those "tweaks" we performed on initial release of FSX where rendered mostly unnecessary following SP2.

Also, and this may sound counter-intuitive, try increasing your frame rates to something around 50, or even Unlimited. FSX handles this setting differently to FS9 and where it use to help, particularly with scenery generation, it can in fact hinder it in FSX. This is often experienced closer to the ground i.e. on approach. In your case it might be affecting your sound reproduction.

If for some reason you really don't want to install SP2 try setting your frame rate to Unlimited and test fly it.

Ken.

airwolfe
02-12-2009, 12:44 PM
If for some reason you really don't want to install SP2 try setting your frame rate to Unlimited and test fly it.

Ken.

I tried unlimited... it's still happening though. I downloaded SP2, I may try that after work. Thanks.