View Full Version : CH Virtual Pilot Pro

09-04-2008, 02:33 PM

Maybe someone can help my friend with the following problem.

He bought (from me :oops:) a CH VPP yoke (analogue) with a gameport connection. Because his pc (with XP) didn't have a gameport he bought a Trust PCI soundcard with gameport. The card is installed and works. But, the CH yoke isn't recognized or can't be calibrated. Now in the device/hardware manager menu the gameport icon has a yellow dot and he gets a message that the device has "not enough resources, code 12" (or something like that).

Does anyone have an idea what the meaning is and how this can be resolved.
On behalf of my friend and me,
thanks for any help,


Trevor Hale
09-04-2008, 02:36 PM
I would think if you goto the Sound card manufacturers website, you could download the Driver for the operating system he is using.

Try that, and see what happens.


09-04-2008, 05:31 PM
Sounds like a possible hardware resource clash.
If the motherboard has onboard sound then you may need to disable it in the Bios settings before installing the new sound card.


09-04-2008, 06:16 PM
Quite likely an IRQ conflict. It should be solveable in the BIOS.

09-04-2008, 06:36 PM
When I had an older gameport connected unit (Thrustmaster TQS) it required a thrustmaster game card. I tried it first through the sound card, no workie! I still have the card but am not using it.

09-05-2008, 05:29 PM

as far as I know we did disable the onboard soundcard before installing the new one.


could you indicate more precisely what to look for in the BIOS and what to change (in a BIOS-for-DUMMIES way ;) )?



Michael Carter
09-05-2008, 06:36 PM
You are looking for a device conflict assigned the same IRQ channel.

You'll need to look through the IRQ list and find out what every device is using. If you find two with the same channel number, assign one of them an unused IRQ channel number.

09-05-2008, 07:53 PM
you could try a gameport to usb adapter there cheap $7-$8 dollars


09-05-2008, 11:40 PM
What BSW said.
If you do not know enough about the BIOS, then best bet is to have someone else do it. You can crash your machine in the BIOS pretty easily.

All newer BIOS have an AUTO-IRQ assign function. Just enable it and it should solve the problem. If your machine does not have it then you will have to hunt down all the IRQs in use and find one that is open.

09-06-2008, 01:14 AM
Now in the device/hardware manager menu the gameport icon has a yellow dot and he gets a message that the device has "not enough resources, code 12" (or something like that).

If you google that, you will find that it is a conflict with a like device. An on-board sound card which has to be disabled in the computers BIOS.

These are the standard irq's for pc's. there are 8 that share irq #7 and play well if the pc is ACPI compliant.

IRQ Number Device
9 Microsoft ACPI-Compliant System
7 NVIDIA GeForce3 Ti 200
7 ALi PCI to USB Open Host Controller
7 Sigma Designs Hollywood Plus MPEG Decoder
7 Advansys SCSI Host Adapter
7 Creative SB Live! Value (WDM)
7 Realtek RTL8139/810X Family PCI Fast Ethernet NIC
7 3Com EtherLink 10/100 PCI TX NIC (3C905B-TX)
7 AMI MegaRAID IDE 100 Controller
14 Primary IDE Channel
15 Secondary IDE Channel
8 System CMOS/real time clock
13 Numeric data processor
6 Standard floppy disk controller
4 Communications Port (COM1)
3 Communications Port (COM2)
12 PS/2 Compatible Mouse
1 Standard 101/102-Key or Microsoft Natural PS/2

You may have an issues with ACPI. Try changing the computer to a standard PC. (http://en.wikipedia.org/wiki/Acpi)

You Do This At Your Own Risk.

1)Right Click My Computer, Select Manage.
2)Opens Management Console.
3)Select Device Manager.
4)Click on the + next to Computer (Top Icon under computer name)
5)Reveals "Advanced Configuration and Power Interface PC"
6)Right click that, select properties.
7)Go into "Driver" tab
8)Click "Update Driver"
10)Display a list of known drivers for the device
12)Click "Show all hardware of this device class"
13)Under (Standard Computers), select "Standard PC"
14)NEXT, NEXT, etc...

15)Reboot and pray.

09-06-2008, 03:20 AM
If it fails to reboot after the above (which I do NOT reccomend unless you know what you're doing) then you will have to reinstall windows. But, just re-install over the old files. Do not re-format the hard drive. That will preserve most of your data that is not in the 'My Documents' folder.

Easier solution.....
Does the machine have a built in sound card? If so, then use it instead.

09-06-2008, 03:47 AM
you could try a gameport to usb adapter there cheap $7-$8 dollars



He tried that in the first place on my advice but it turned out that although the yoke functioned, he couldn't assign the buttons and hat switches properly. Furthermore the calibration got lost time and again, so on every startup he had to recalibrate.
That's why we thought going for a proper gameport would do the trick.

To the other guys, thanx for the suggestions. I'll pass them on and see what happens.