PDA

View Full Version : Problem with IOCards Master Card



phantomlord2k
08-22-2007, 12:15 PM
I'm posting here because I have yet to get any answers from the OpenCockpits forum or support:

I now have my master card and display cards assembled and I've been testing all the connections. All LED outputs work and so far all display digits work. However, on the master card of J3 and J4 only half of my inputs are working with controllador when I test them. The following inputs are not working:

3,5,6,7,8,11,14,15,16,17,23,24,25,26,,32,33,34,35 on J3

39,41,42,43,44,50,51,52,53,59,60,61,62,65,68,69,70,71 on J4

Can anyone help me with this problem? Seems like something major to have that many not working. Is it possible one of the chips is bad? Or could it be the compatibility of the parallel cable/settings? I am NOT using the USB card at this time. I could build the "compatible cable" if needed, but I would need to order the IC and I don't want to spend $6 shipping on a 53 cent part right now until I need more hardware from my supplier to make the order worth it.

Thanks!!

dnoize
08-22-2007, 12:45 PM
have you tried changing the parralel port settings in your bios ?

The card doesnt work with all possible protocols for the parralel port.

Stef

Kennair
08-23-2007, 09:23 AM
Hi phantomlord2k(?)

Excuse me if I'm preaching to the converted, but I'd start by testing all your diodes and make sure they are round the right way (won't work if they're backwards) and work back from the J3/4 pins to the offending break. Look for the common element in all your errant connections using the circuit diagram for the card. I had a similar problem when I built mine (and also got no response from OpenCockpit) but through trial and error I tested the legs of one of the IC's and found it shorted to ground. I think it was a '74HC541'. All the IC's on the card should be available from your local electronics retailer as there's nothing special about them. I picked one up for $1.50 and it fixed the problem. Could be other issues though, you'll just have to persevere.

Hope that helps,

Ken

phantomlord2k
08-25-2007, 06:15 PM
I have tried every parallel port setting in the BIOS and it didn't make a difference. I also checked and all of the diodes are mounted correctly. If I start checking the IC pins like you suggested, what exactly am I looking for? I do have a DMM so I can check the circuit if I know what I'm looking for. I did read somewhere that if the parallel port/cable is not fully compatible, you will have a certain number of inputs that will not work. If I can't find the problem, I may just wait until I place another order with Mouser and get the chip to build the "compatible cable". Unfortunately I live in a place where there is no electronics store I can buy ICs from or I would build the cable now. All we have is a Radio Shack that carries very little.

dcutugno
08-26-2007, 08:09 AM
I had the same problem in others PC, Only 1 got to work changing the Bios port setting, i solved that using USB.

Kennair
08-26-2007, 11:56 AM
Yes I must say that I have always used the USB expansion card for Master Card connection, so haven't experimented with the parallel cable. As far as I am aware it just requires a straight 25 pin cable like a printer. However the cfg file in the IO directory also has to have the relevant entries to match your cable and port.

As far as a faulty IC goes, if it's shorting to ground, then it will probably feel quite hot, if it is damaged and just not making all connections, you need to check each pin. I downloaded the spec sheet on the chip (just google it) and used that along with the circuit diagram for the master card itself. Trial and error I'm afraid, but unless you can get yourself to Spain, there's not much option.

Good luck.

Ken.